Skip to content
Heist/ feed
Back to feed
Medium

phpMyFAQ Stored XSS at user email

Type: advisorySources: OSV

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The `email` field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's `FILTER_VALIDATE_EMAIL` function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. This vulnerability is fixed in 3.2.6.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-27300
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 05:48 UTC · Revision 1

Source evidence

phpMyFAQ Stored XSS at user email

core-osv · Original source

Published 25 Mar 2024, 18:30 UTC

phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The `email` field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's `FILTER_VALIDATE_EMAIL` function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. This vulnerability is fixed in 3.2.6.

osv:CVE-2024-27300
Complete source record
{
  "id": "93f12fa26790b7a90a19305fc78668d7d33b3200a0cf1b0db2a9cab96eb7a29c",
  "url": "https://osv.dev/vulnerability/CVE-2024-27300",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "phpMyFAQ Stored XSS at user email",
    "summary": "phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. The `email` field in phpMyFAQ's user control panel page is vulnerable to stored XSS attacks due to the inadequacy of PHP's `FILTER_VALIDATE_EMAIL` function, which only validates the email format, not its content. This vulnerability enables an attacker to execute arbitrary client-side JavaScript within the context of another user's phpMyFAQ session. This vulnerability is fixed in 3.2.6.",
    "evidence": "osv:CVE-2024-27300",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-27300",
      "aliases": [
        "CVE-2024-27300",
        "GHSA-q7g6-xfh2-vhpx"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/thorsten/phpmyfaq",
              "type": "GIT",
              "events": [
                {
                  "introduced": "ee05654763ef0f16137d3bd21ec50e2f21ffb8f8"
                },
                {
                  "fixed": "09336b0ff0e0a04aa0c97c5975651af4769d2459"
                },
                {
                  "fixed": "de90315c9bd4ead5fe6ba5586f6b016843aa8209"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "3.2.5"
                      },
                      {
                        "last_affected": "3.2.5"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandaloneSingleVersion"
                  },
                  {
                    "range": [
                      {
                        "fixed": "09336b0ff0e0a04aa0c97c5975651af4769d2459"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "de90315c9bd4ead5fe6ba5586f6b016843aa8209"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "3.2.5"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-27300.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:26.203141883Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27300.json",
        "https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-q7g6-xfh2-vhpx",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-27300",
        "https://github.com/thorsten/phpMyFAQ/commit/09336b0ff0e0a04aa0c97c5975651af4769d2459",
        "https://github.com/thorsten/phpMyFAQ/commit/de90315c9bd4ead5fe6ba5586f6b016843aa8209"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27300.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-27300",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 492852,
  "published_at": "2024-03-25T18:30:35.81+00:00"
}