Medium
Security advisory
phpList before 3.6.15 is vulnerable to Cross-Site Scripting (XSS) due to improper input sanitization in lt.php. The vulnerability is exploitable when the application dynamically references internal paths and processes untrusted input without escaping, allowing an attacker to inject malicious JavaScript.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-28074
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 23:32 UTC · Revision 1
Source evidence
phpList before 3.6.15 is vulnerable to Cross-Site Scripting (XSS) due to improper input sanitization in lt.php. The vulnerability is exploitable when the application dynamically references internal paths and processes untrusted input without escaping, allowing an attacker to inject malicious JavaScript.
osv:CVE-2025-28074
Complete source record
{
"id": "f2f032d841627fa9221028cb18b5ea56110f60941a344eb58fb89d6dcdacb680",
"url": "https://osv.dev/vulnerability/CVE-2025-28074",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2025-28074",
"summary": "phpList before 3.6.15 is vulnerable to Cross-Site Scripting (XSS) due to improper input sanitization in lt.php. The vulnerability is exploitable when the application dynamically references internal paths and processes untrusted input without escaping, allowing an attacker to inject malicious JavaScript.",
"evidence": "osv:CVE-2025-28074",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-28074",
"aliases": [
"CVE-2025-28074"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phplist/phplist3",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8bfc783f8e98432435500e6d0b46d7ff8da42e9b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "3.6.15"
}
],
"source": "DESCRIPTION"
},
{
"cpe": "cpe:2.3:a:phplist:phplist:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.6.15"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.6.15-RC2",
"v3.6.15-RC1",
"v3.6.12-RC2",
"v3.6.12",
"v3.6.11-RC1",
"v3.6.11",
"v3.6.12-RC",
"v3.6.9-RC2",
"v3.6.9-RC1",
"v3.6.8-RC2",
"v3.6.8",
"v3.6.8-RC1",
"v3.6.7-RC2",
"v3.6.7-RC1",
"v3.6.6",
"v3.6.6-RC3",
"v3.6.5",
"v3.6.4-RC2",
"v3.6.3",
"v3.6.3-RC2",
"v3.6.3-RC1",
"3.6.2",
"3.6.1",
"3.6.0",
"3.5.9",
"3.5.8",
"3.5.7",
"3.5.6",
"3.5.5",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.0",
"3.4.9",
"3.4.8",
"3.4.7",
"3.4.6",
"3.4.5",
"3.4.4",
"v.3.3.8",
"3.3.6",
"v.3.3.5",
"v3.2.7",
"v3.2.1",
"3.2.0",
"3.2.0-RC1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-28074.json"
}
}
],
"modified": "2026-10-28T02:30:40.635232505Z",
"provider": "osv",
"references": [
"https://github.com/phpList/phplist3/blob/main/public_html/lists/lt.php",
"https://github.com/phpList/phplist3/compare/v3.6.14...v3.6.15",
"https://www.phplist.org/newslist/phplist-3-6-15-release-notes/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/28xxx/CVE-2025-28074.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-28074",
"https://github.com/mLniumm/CVE-2025-28074"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/28xxx/CVE-2025-28074.json"
}
},
"related_cves": [
{
"value": "CVE-2025-28074",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 508000,
"published_at": "2025-05-08T00:00:00+00:00"
}