Unrated
Directorist < 7.3.0 - Subscriber+ Arbitrary E-mail Sending
Type: advisorySources: OSV
The Directorist WordPress plugin before 7.3.0 does not have authorisation and CSRF checks in an AJAX action, allowing any authenticated users to send arbitrary emails on behalf of the blog
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-2377
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 08:56 UTC · Revision 1
Source evidence
Directorist < 7.3.0 - Subscriber+ Arbitrary E-mail Sending
core-osv · Original sourcePublished 22 Aug 2022, 15:02 UTC
The Directorist WordPress plugin before 7.3.0 does not have authorisation and CSRF checks in an AJAX action, allowing any authenticated users to send arbitrary emails on behalf of the blog
osv:CVE-2022-2377
Complete source record
{
"id": "5b1cb38f57fb31e9794b7abb5d6cd1ec3a88dfe325b165803a3ada0c3c297b2c",
"url": "https://osv.dev/vulnerability/CVE-2022-2377",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Directorist < 7.3.0 - Subscriber+ Arbitrary E-mail Sending",
"summary": "The Directorist WordPress plugin before 7.3.0 does not have authorisation and CSRF checks in an AJAX action, allowing any authenticated users to send arbitrary emails on behalf of the blog",
"evidence": "osv:CVE-2022-2377",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-2377",
"aliases": [
"CVE-2022-2377"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/sovware/directorist",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "3c07f8a6e9adbc21114e48d64ecb5f92ef7a4e12"
}
],
"database_specific": {
"cpe": "cpe:2.3:a:wpwax:directorist:*:*:*:*:*:wordpress:*:*",
"source": "CPE_RANGE",
"extracted_events": [
{
"introduced": "0"
},
{
"fixed": "7.3.0"
}
]
}
}
],
"versions": [
"v7.2.2",
"v7.2.1",
"v7.2.0",
"v7.1.2",
"v7.1.1",
"v7.1.0",
"v7.0.8",
"v7.0.7",
"v7.0.6.3",
"v7.0.6.2",
"v7.0.6.1",
"v7.0.6",
"v7.0.5.6",
"v7.0.5.4",
"v7.0.5.3",
"v7.0.5.2",
"v7.0.5.1",
"v7.0.5",
"v7.0.4.1",
"released-v7.0.4",
"v7.0.3.3",
"v7.0.3.2",
"v7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-2377.json"
}
}
],
"modified": "2026-10-08T02:46:45.904752740Z",
"provider": "osv",
"references": [
"https://wpscan.com/vulnerability/f4e606e9-0664-42fb-a59b-21de306eb530",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2377.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-2377"
],
"provider_metadata": {
"cwe_ids": [
"CWE-352",
"CWE-862"
],
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"source": "AFFECTED_FIELD",
"extracted_events": [
{
"introduced": "7.3.0"
},
{
"last_affected": "7.3.0"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2377.json"
}
},
"related_cves": [
{
"value": "CVE-2022-2377",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 98231,
"published_at": "2022-08-22T15:02:09+00:00"
}