Post SMTP <= 3.0.2 - Unauthenticated Stored Cross-Site Scripting
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the from and subject parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-0521
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:24 UTC · Revision 1
Source evidence
Post SMTP <= 3.0.2 - Unauthenticated Stored Cross-Site Scripting
core-osv · Original sourcePublished 18 Feb 2025, 11:10 UTC
The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the from and subject parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
osv:CVE-2025-0521
Complete source record
{
"id": "958098a7fb3788a5a346bd28dafb5de80ba1db7e2853b7d47cef258b14181aa3",
"url": "https://osv.dev/vulnerability/CVE-2025-0521",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post SMTP <= 3.0.2 - Unauthenticated Stored Cross-Site Scripting",
"summary": "The Post SMTP plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the from and subject parameter in all versions up to, and including, 3.0.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.",
"evidence": "osv:CVE-2025-0521",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-0521",
"aliases": [
"CVE-2025-0521"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "07a6b179650224fc5d3a119f3623ec12f4031194"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.0.1",
"3.0.0",
"3.0.0-rc.1",
"3.0.0-beta.1",
"2.9.9",
"2.9.8",
"2.9.7",
"2.9.6",
"2.9.5",
"2.5.9-beta.1",
"2.9.3",
"2.9.2",
"2.9.1",
"2.9.0",
"2.8.8",
"2.8.7",
"2.8.5",
"2.8.4",
"2.7.0",
"2.8.3",
"2.7.2",
"2.6.0",
"2.5.9.4",
"2.5.9.3",
"2.5.8",
"2.5.7",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.3",
"2.5.2",
"2.5.1",
"2.5.0",
"2.5-rc.3",
"2.5-rc.2",
"2.5-rc.1",
"2.5-beta.1",
"2.4.3",
"2.4.2-beta.2",
"2.4.2",
"2.4.1",
"2.4",
"2.4-beta.1",
"2.3.1",
"2.3",
"2.2.1",
"2.2",
"2.2-beta.2",
"2.1.8",
"2.1.7",
"2.1.6",
"2.1.4",
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-0521.json"
}
}
],
"modified": "2026-10-28T02:30:24.880360846Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=3237626%40post-smtp%2Ftrunk&old=3229076%40post-smtp%2Ftrunk&sfp_email=&sfph_mail=",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/366dfbf1-870c-4ce3-abc4-a2b2f4e72175?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/0xxx/CVE-2025-0521.json",
"https://nvd.nist.gov/vuln/detail/CVE-2025-0521"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "3.0.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/0xxx/CVE-2025-0521.json"
}
},
"related_cves": [
{
"value": "CVE-2025-0521",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491604,
"published_at": "2025-02-18T11:10:18.504+00:00"
}