Medium
Security advisory
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-20921
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:03 UTC · Revision 1
Source evidence
bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.
osv:CVE-2019-20921
Complete source record
{
"id": "a6a30521eae64feb4087e4281b46d2b563c4ce4150992c640c90d245c7a95608",
"url": "https://osv.dev/vulnerability/CVE-2019-20921",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-20921",
"summary": "bootstrap-select before 1.13.6 allows Cross-Site Scripting (XSS). It does not escape title values in OPTION elements. This may allow attackers to execute arbitrary JavaScript in a victim's browser.",
"evidence": "osv:CVE-2019-20921",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2019-20921",
"aliases": [
"CVE-2019-20921",
"GHSA-7c82-mp33-r854",
"GHSA-9r7h-6639-v5mw",
"SNYK-JS-BOOTSTRAPSELECT-570457"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/snapappointments/bootstrap-select",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "728c4c6e92124a9f00c7f4f3f99c39ab1375c054"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:snapappointments:bootstrap-select:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.13.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v1.13.5",
"v1.13.4",
"v1.13.3",
"v1.13.2",
"v1.13.1",
"v1.13.0",
"v1.13.0-beta",
"v1.13.0-alpha",
"v1.12.4",
"v1.12.3",
"v1.12.2",
"v1.12.1",
"v1.12.0",
"v1.11.2",
"v1.11.1",
"v1.11.0",
"v1.10.0",
"v1.9.4",
"v1.9.3",
"v1.9.2",
"1.9.1",
"1.9.0",
"v1.8.1",
"v1.8.0",
"v1.7.7",
"v1.7.5",
"v1.7.4",
"v1.7.3",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.7.0-rc6",
"v1.7.0-rc5",
"v1.7.0-rc4",
"v1.7.0-rc3",
"v1.7.0-rc2",
"v1.7.0-rc1",
"v1.6.5",
"v1.6.4",
"v1.6.3",
"v1.6.2",
"v1.6.1",
"v1.6.0",
"1.5.4",
"1.5.2",
"1.5.1",
"1.5.0",
"1.4.3",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.7",
"1.3.6",
"1.3.5",
"1.3.4",
"1.3.3",
"1.3.1",
"1.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-20921.json"
}
}
],
"modified": "2026-10-20T10:52:41.217196951Z",
"provider": "osv",
"references": [
"https://issues.jtl-software.de/issues/SHOP-7964",
"https://github.com/advisories/GHSA-9r7h-6639-v5mw",
"https://snyk.io/vuln/SNYK-JS-BOOTSTRAPSELECT-570457",
"https://www.npmjs.com/advisories/1522",
"https://github.com/snapappointments/bootstrap-select/issues/2199"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-20921",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 383738,
"published_at": "2020-09-30T18:15:18.007+00:00"
}