MediumFix available
apr-util — security advisory
Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.
- Products
- apr-util
- Affected versions
- Not specified
- Fixed versions
- 1.6.3-1
- CVEs
- CVE-2022-25147
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:47 UTC · Revision 1
Source evidence
Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.
osv:DEBIAN-CVE-2022-25147
apr-util
Fixed versions: 1.6.3-1
apr-util
Fixed versions: 1.6.3-1
apr-util
Fixed versions: 1.6.3-1
Complete source record
{
"id": "37a45c317a4238c07e84bf7a88f8fcbb92bc44dd086f9ead915ec2a32fae60f1",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-25147",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-25147",
"summary": "Integer Overflow or Wraparound vulnerability in apr_base64 functions of Apache Portable Runtime Utility (APR-util) allows an attacker to write beyond bounds of a buffer. This issue affects Apache Portable Runtime Utility (APR-util) 1.6.1 and prior versions.",
"evidence": "osv:DEBIAN-CVE-2022-25147",
"products": [
{
"name": {
"value": "apr-util",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apr-util",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "apr-util",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6.3-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-25147",
"aliases": [
"DEBIAN-CVE-2022-25147"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.3-1"
}
]
}
],
"package": {
"name": "apr-util",
"purl": "pkg:deb/debian/apr-util?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25147.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.3-1"
}
]
}
],
"package": {
"name": "apr-util",
"purl": "pkg:deb/debian/apr-util?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25147.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6.3-1"
}
]
}
],
"package": {
"name": "apr-util",
"purl": "pkg:deb/debian/apr-util?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25147.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:11.079061018Z",
"provider": "osv",
"upstream": [
"CVE-2022-25147"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-25147"
]
},
"related_cves": [
{
"value": "CVE-2022-25147",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323303,
"published_at": "2023-01-31T16:15:08.907+00:00"
}