Skip to content
Heist/ feed
Back to feed
Medium

WordPress BuddyPress Plugin <= 11.3.1 is vulnerable to Cross Site Scripting (XSS)

Type: advisorySources: OSV

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in The BuddyPress Community BuddyPress allows Stored XSS.This issue affects BuddyPress: from n/a through 11.3.1.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2023-50880
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 02:55 UTC · Revision 1

Source evidence

WordPress BuddyPress Plugin <= 11.3.1 is vulnerable to Cross Site Scripting (XSS)

core-osv · Original source

Published 29 Dec 2023, 11:28 UTC

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in The BuddyPress Community BuddyPress allows Stored XSS.This issue affects BuddyPress: from n/a through 11.3.1.

osv:CVE-2023-50880
Complete source record
{
  "id": "26f70222991e88a6c7a6d528bbcce8bd08a16022f24815dfdec82b9a5dea0e67",
  "url": "https://osv.dev/vulnerability/CVE-2023-50880",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "WordPress BuddyPress Plugin <= 11.3.1 is vulnerable to Cross Site Scripting (XSS)",
    "summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in The BuddyPress Community BuddyPress allows Stored XSS.This issue affects BuddyPress: from n/a through 11.3.1.",
    "evidence": "osv:CVE-2023-50880",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2023-50880",
      "aliases": [
        "CVE-2023-50880"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/buddypress/buddypress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "4081b7688976a822288d4a982a12ccfb280c09e7"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:buddypress:buddypress:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "11.3.1"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "11.3.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-50880.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:48.979558371Z",
      "provider": "osv",
      "references": [
        "https://wordpress.org/plugins",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50880.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2023-50880",
        "https://patchstack.com/database/vulnerability/buddypress/wordpress-buddypress-plugin-11-3-1-cross-site-scripting-xss-vulnerability?_s_id=cve"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "Patchstack",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "11.3.2"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "ChangesAt"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/50xxx/CVE-2023-50880.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2023-50880",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 517542,
  "published_at": "2023-12-29T11:28:39.308+00:00"
}