Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-016

Type: patchSources: Drupal security

Drupal core contains an XSS vulnerability in the Navigation module caused by insufficient sanitization of certain attributes. Exploitation requires a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission. Update to a listed fixed version.

Products
Drupal core
Affected versions
>= 10.3.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2
Fixed versions
10.6.19, 11.3.19, 11.4.10
CVEs
CVE-2026-108514
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:45 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-016

official-drupal-security · Original source

Published 14 Oct 2026, 17:25 UTC

Drupal core contains an XSS vulnerability in the Navigation module caused by insufficient sanitization of certain attributes. Exploitation requires a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission. Update to a listed fixed version.

The Navigation module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission.

Drupal core

Fixed versions: 11.4.10, 11.3.19, 10.6.19

Prerequisites: an attacker must have a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission

Complete source record
{
  "id": "1278c1ea9d4488f349127c60923ef08148f516e4293d7ba2d7f9a4fbaa062193",
  "url": "https://www.drupal.org/sa-core-2026-016",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Cross-site scripting - SA-CORE-2026-016",
    "summary": "Drupal core contains an XSS vulnerability in the Navigation module caused by insufficient sanitization of certain attributes. Exploitation requires a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission. Update to a listed fixed version.",
    "evidence": "The Navigation module doesn't sufficiently sanitize certain attributes, which can lead to a cross-site scripting (XSS) vulnerability. This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission.",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [
          {
            "value": "an attacker must have a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission",
            "evidence": "This vulnerability is mitigated by the fact that an attacker must have a role with permission to enter HTML tags containing specific data attributes, or the administer menu permission."
          }
        ],
        "fixed_versions": [
          {
            "value": "11.4.10",
            "evidence": "If you use Drupal 11.4.x, update to Drupal 11.4.10."
          },
          {
            "value": "11.3.19",
            "evidence": "If you use Drupal 11.3.x, update to Drupal 11.3.19."
          },
          {
            "value": "10.6.19",
            "evidence": "If you use Drupal 10.6.x, update to Drupal 10.6.19."
          }
        ],
        "affected_versions": [
          {
            "value": ">= 10.3.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2",
            "evidence": "Affected versions: >= 10.3.0 < 10.6.19 || >= 11.0.0 < 11.3.19 || >= 11.4.0 < 11.4.10 || >= 12.0.0-alpha1 < 12.0.0-beta2"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2026-108514",
        "evidence": "CVE IDs: CVE-2026-108514"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23455,
  "published_at": "2026-10-14T17:25:38+00:00"
}