linuxptp — security advisory
A flaw was found in the ptp4l program of the linuxptp package. A missing length check when forwarding a PTP message between ports allows a remote attacker to cause an information leak, crash, or potentially remote code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. This flaw affects linuxptp versions before 3.1.1, before 2.0.1, before 1.9.3, before 1.8.1, before 1.7.1, before 1.6.1 and before 1.5.1.
- Products
- linuxptp
- Affected versions
- Not specified
- Fixed versions
- 3.1-2.1
- CVEs
- CVE-2021-3570
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 00:36 UTC · Revision 1
Source evidence
A flaw was found in the ptp4l program of the linuxptp package. A missing length check when forwarding a PTP message between ports allows a remote attacker to cause an information leak, crash, or potentially remote code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. This flaw affects linuxptp versions before 3.1.1, before 2.0.1, before 1.9.3, before 1.8.1, before 1.7.1, before 1.6.1 and before 1.5.1.
osv:DEBIAN-CVE-2021-3570
linuxptp
Fixed versions: 3.1-2.1
linuxptp
Fixed versions: 3.1-2.1
linuxptp
Fixed versions: 3.1-2.1
Complete source record
{
"id": "89f1d7207a1fe6f1c5b73eedfe4be19c2804de1203269d5f0525290840d09e85",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-3570",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-3570",
"summary": "A flaw was found in the ptp4l program of the linuxptp package. A missing length check when forwarding a PTP message between ports allows a remote attacker to cause an information leak, crash, or potentially remote code execution. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability. This flaw affects linuxptp versions before 3.1.1, before 2.0.1, before 1.9.3, before 1.8.1, before 1.7.1, before 1.6.1 and before 1.5.1.",
"evidence": "osv:DEBIAN-CVE-2021-3570",
"products": [
{
"name": {
"value": "linuxptp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.1-2.1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linuxptp",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.1-2.1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linuxptp",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.1-2.1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2021-3570",
"aliases": [
"DEBIAN-CVE-2021-3570"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1-2.1"
}
]
}
],
"package": {
"name": "linuxptp",
"purl": "pkg:deb/debian/linuxptp?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3570.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1-2.1"
}
]
}
],
"package": {
"name": "linuxptp",
"purl": "pkg:deb/debian/linuxptp?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3570.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1-2.1"
}
]
}
],
"package": {
"name": "linuxptp",
"purl": "pkg:deb/debian/linuxptp?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3570.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:03:29.595905348Z",
"provider": "osv",
"upstream": [
"CVE-2021-3570"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-3570"
]
},
"related_cves": [
{
"value": "CVE-2021-3570",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 421680,
"published_at": "2021-07-09T11:15:08.723+00:00"
}