Medium
WordPress Geo Mashup plugin <= 1.13.12 - Cross Site Scripting (XSS) vulnerability
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dylan Kuhn Geo Mashup geo-mashup allows Stored XSS.This issue affects Geo Mashup: from n/a through <= 1.13.12.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-44008
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 03:43 UTC · Revision 1
Source evidence
WordPress Geo Mashup plugin <= 1.13.12 - Cross Site Scripting (XSS) vulnerability
core-osv · Original sourcePublished 17 Sept 2024, 23:03 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dylan Kuhn Geo Mashup geo-mashup allows Stored XSS.This issue affects Geo Mashup: from n/a through <= 1.13.12.
osv:CVE-2024-44008
Complete source record
{
"id": "e2b219867cf1907b83bbdc39540ed8b76ac3ceb84f68b3e3b577ad72dba9a603",
"url": "https://osv.dev/vulnerability/CVE-2024-44008",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Geo Mashup plugin <= 1.13.12 - Cross Site Scripting (XSS) vulnerability",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Dylan Kuhn Geo Mashup geo-mashup allows Stored XSS.This issue affects Geo Mashup: from n/a through <= 1.13.12.",
"evidence": "osv:CVE-2024-44008",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-44008",
"aliases": [
"CVE-2024-44008"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cyberhobo/wordpress-geo-mashup",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "13db512167085693382b65cfc305240e48c43b58"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:cyberhobo:geo_mashup:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.13.13"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"1.13.12",
"1.13.11",
"1.13.10",
"1.13.7",
"1.13.6",
"1.13.5",
"1.13.4",
"1.13.3",
"1.13.2",
"1.13.1",
"1.13.0",
"1.12.3",
"1.12.2",
"1.12.1",
"1.12.0",
"1.11.3",
"1.11.2",
"1.11.1",
"1.11.0",
"1.10.5",
"1.10.4",
"1.10.2",
"1.10.1",
"1.10.0",
"1.9.1",
"1.9.0",
"1.8.9",
"1.8.8",
"1.8.7",
"1.8.6",
"1.8.5",
"1.8.4",
"1.8.3",
"1.8.2",
"1.8.1",
"1.8.0",
"1.7.3",
"1.7.2",
"1.7.1",
"1.7.0",
"1.6.2",
"1.6.1",
"1.6.0",
"1.6-beta1",
"1.5.3",
"1.5.2",
"1.5.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-44008.json"
}
}
],
"modified": "2026-10-28T02:30:53.302308331Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/44xxx/CVE-2024-44008.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-44008",
"https://patchstack.com/database/Wordpress/Plugin/geo-mashup/vulnerability/wordpress-geo-mashup-plugin-1-13-12-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "1.13.13"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/44xxx/CVE-2024-44008.json"
}
},
"related_cves": [
{
"value": "CVE-2024-44008",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 522306,
"published_at": "2024-09-17T23:03:39.853+00:00"
}