UnratedFix available
qemu — security advisory
Heap-based buffer overflow in the Cirrus VGA emulator (hw/display/cirrus_vga.c) in QEMU before 2.2.0 allows local guest users to execute arbitrary code via vectors related to blit regions. NOTE: this vulnerability exists because an incomplete fix for CVE-2007-1320.
- Products
- qemu
- Affected versions
- Not specified
- Fixed versions
- 2.1+dfsg-9
- CVEs
- CVE-2014-8106
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:39 UTC · Revision 1
Source evidence
Heap-based buffer overflow in the Cirrus VGA emulator (hw/display/cirrus_vga.c) in QEMU before 2.2.0 allows local guest users to execute arbitrary code via vectors related to blit regions. NOTE: this vulnerability exists because an incomplete fix for CVE-2007-1320.
osv:DEBIAN-CVE-2014-8106
qemu
Fixed versions: 2.1+dfsg-9
qemu
Fixed versions: 2.1+dfsg-9
qemu
Fixed versions: 2.1+dfsg-9
Complete source record
{
"id": "0fc986d7d05c336a0f102a66be4fab71413754c725be65ecf67da69028afc221",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2014-8106",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2014-8106",
"summary": "Heap-based buffer overflow in the Cirrus VGA emulator (hw/display/cirrus_vga.c) in QEMU before 2.2.0 allows local guest users to execute arbitrary code via vectors related to blit regions. NOTE: this vulnerability exists because an incomplete fix for CVE-2007-1320.",
"evidence": "osv:DEBIAN-CVE-2014-8106",
"products": [
{
"name": {
"value": "qemu",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1+dfsg-9",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "qemu",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1+dfsg-9",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "qemu",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2.1+dfsg-9",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "unknown",
"structured": {
"id": "DEBIAN-CVE-2014-8106",
"aliases": [
"DEBIAN-CVE-2014-8106"
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1+dfsg-9"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8106.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1+dfsg-9"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8106.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2.1+dfsg-9"
}
]
}
],
"package": {
"name": "qemu",
"purl": "pkg:deb/debian/qemu?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2014-8106.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T15:47:28.929720015Z",
"provider": "osv",
"upstream": [
"CVE-2014-8106"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2014-8106"
]
},
"related_cves": [
{
"value": "CVE-2014-8106",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 413987,
"published_at": "2014-12-08T16:59:01.37+00:00"
}