gh — security advisory
GitHub CLI (gh) is GitHub’s official command line tool. From 2.10.0 through 2.95.0, connecting to a malicious Codespace with gh codespace jupyter can allow command execution because the command opens a JupyterLab URL supplied by a process inside the Codespace without validating that it is a loopback HTTP or HTTPS address, allowing a crafted vscode:// or vscode-insiders:// URL to be handed to VS Code. This issue is fixed in version 2.96.0.
- Products
- gh
- Affected versions
- 2.27.0+dfsg1-1build1, 2.30.0-2, 2.35.0-1, 2.4.0+dfsg1-1, 2.4.0+dfsg1-2, 2.40.1+dfsg1-1, 2.42.1-1, 2.43.1-1, 2.44.1-1, 2.44.1-2, 2.45.0-1, 2.45.0-1build1, 2.45.0-1ubuntu0.1, 2.45.0-1ubuntu0.2, 2.45.0-1ubuntu0.2+esm1, 2.45.0-1ubuntu0.2+esm2, 2.45.0-1ubuntu0.3, 2.45.0-1ubuntu0.3+esm1, 2.45.0-1ubuntu0.3+esm2, 2.45.0-1ubuntu0.3+esm3, 2.46.0-3, 2.46.0-4, 2.46.0-4ubuntu0.26.04.1~esm1
- Fixed versions
- Not specified
- CVEs
- CVE-2026-59831
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 03:10 UTC · Revision 1
Source evidence
GitHub CLI (gh) is GitHub’s official command line tool. From 2.10.0 through 2.95.0, connecting to a malicious Codespace with gh codespace jupyter can allow command execution because the command opens a JupyterLab URL supplied by a process inside the Codespace without validating that it is a loopback HTTP or HTTPS address, allowing a crafted vscode:// or vscode-insiders:// URL to be handed to VS Code. This issue is fixed in version 2.96.0.
osv:UBUNTU-CVE-2026-59831
gh
Fixed versions: Not specified
gh
Fixed versions: Not specified
gh
Fixed versions: Not specified
gh
Fixed versions: Not specified
Complete source record
{
"id": "1ab49888dd3f13631fd0999f08192fdc99db53d9c3565204e92d7f0d0e500929",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2026-59831",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2026-59831",
"summary": "GitHub CLI (gh) is GitHub’s official command line tool. From 2.10.0 through 2.95.0, connecting to a malicious Codespace with gh codespace jupyter can allow command execution because the command opens a JupyterLab URL supplied by a process inside the Codespace without validating that it is a loopback HTTP or HTTPS address, allowing a crafted vscode:// or vscode-insiders:// URL to be handed to VS Code. This issue is fixed in version 2.96.0.",
"evidence": "osv:UBUNTU-CVE-2026-59831",
"products": [
{
"name": {
"value": "gh",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.4.0+dfsg1-1",
"evidence": "/affected/0/versions"
},
{
"value": "2.4.0+dfsg1-2",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "gh",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.27.0+dfsg1-1build1",
"evidence": "/affected/1/versions"
},
{
"value": "2.30.0-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.35.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.40.1+dfsg1-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.42.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.43.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.44.1-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.44.1-2",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1build1",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.1",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.2",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.2+esm1",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.2+esm2",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.3",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.3+esm1",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.3+esm2",
"evidence": "/affected/1/versions"
},
{
"value": "2.45.0-1ubuntu0.3+esm3",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "gh",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.46.0-4",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "gh",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "2.46.0-3",
"evidence": "/affected/3/versions"
},
{
"value": "2.46.0-4",
"evidence": "/affected/3/versions"
},
{
"value": "2.46.0-4ubuntu0.26.04.1~esm1",
"evidence": "/affected/3/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "UBUNTU-CVE-2026-59831",
"aliases": [
"UBUNTU-CVE-2026-59831"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gh",
"purl": "pkg:deb/ubuntu/gh?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"2.4.0+dfsg1-1",
"2.4.0+dfsg1-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-59831.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gh",
"binary_version": "2.4.0+dfsg1-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gh",
"purl": "pkg:deb/ubuntu/gh?arch=source&distro=esm-apps%2Fnoble",
"ecosystem": "Ubuntu:Pro:24.04:LTS"
},
"versions": [
"2.27.0+dfsg1-1build1",
"2.30.0-2",
"2.35.0-1",
"2.40.1+dfsg1-1",
"2.42.1-1",
"2.43.1-1",
"2.44.1-1",
"2.44.1-2",
"2.45.0-1",
"2.45.0-1build1",
"2.45.0-1ubuntu0.1",
"2.45.0-1ubuntu0.2",
"2.45.0-1ubuntu0.2+esm1",
"2.45.0-1ubuntu0.2+esm2",
"2.45.0-1ubuntu0.3",
"2.45.0-1ubuntu0.3+esm1",
"2.45.0-1ubuntu0.3+esm2",
"2.45.0-1ubuntu0.3+esm3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-59831.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gh",
"binary_version": "2.45.0-1ubuntu0.3+esm3"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gh",
"purl": "pkg:deb/ubuntu/gh?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"2.46.0-4"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-59831.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gh",
"binary_version": "2.46.0-4"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "gh",
"purl": "pkg:deb/ubuntu/gh?arch=source&distro=esm-apps%2Fresolute",
"ecosystem": "Ubuntu:Pro:26.04:LTS"
},
"versions": [
"2.46.0-3",
"2.46.0-4",
"2.46.0-4ubuntu0.26.04.1~esm1"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2026/UBUNTU-CVE-2026-59831.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "gh",
"binary_version": "2.46.0-4ubuntu0.26.04.1~esm1"
}
]
}
}
],
"modified": "2026-10-17T13:00:29.109073310Z",
"provider": "osv",
"upstream": [
"CVE-2026-59831"
],
"references": [
"https://ubuntu.com/security/CVE-2026-59831",
"https://www.cve.org/CVERecord?id=CVE-2026-59831",
"https://github.com/cli/cli/security/advisories/GHSA-8cg3-r6g9-fpg2",
"https://github.com/cli/cli/commit/b300f2ec7ec9dc9addc39b2ad88c54097ded7ca0",
"https://github.com/cli/cli/releases/tag/v2.96.0"
]
},
"related_cves": [
{
"value": "CVE-2026-59831",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 360598,
"published_at": "2026-07-09T23:17:00+00:00"
}