Skip to content
Heist/ feed
Back to feed
High

Apache Traffic Server: HTTP/2 CONTINUATION frames can be utilized for DoS attack

Type: advisorySources: OSV

HTTP/2 CONTINUATION DoS attack can cause Apache Traffic Server to consume more resources on the server. Version from 8.0.0 through 8.1.9, from 9.0.0 through 9.2.3 are affected. Users can set a new setting (proxy.config.http2.max_continuation_frames_per_minute) to limit the number of CONTINUATION frames per minute. ATS does have a fixed amount of memory a request can use and ATS adheres to these limits in previous releases. Users are recommended to upgrade to versions 8.1.10 or 9.2.4 which fixes the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-31309
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 18:44 UTC · Revision 1

Source evidence

Apache Traffic Server: HTTP/2 CONTINUATION frames can be utilized for DoS attack

core-osv · Original source

Published 10 Apr 2024, 12:07 UTC

HTTP/2 CONTINUATION DoS attack can cause Apache Traffic Server to consume more resources on the server. Version from 8.0.0 through 8.1.9, from 9.0.0 through 9.2.3 are affected. Users can set a new setting (proxy.config.http2.max_continuation_frames_per_minute) to limit the number of CONTINUATION frames per minute. ATS does have a fixed amount of memory a request can use and ATS adheres to these limits in previous releases. Users are recommended to upgrade to versions 8.1.10 or 9.2.4 which fixes the issue.

osv:CVE-2024-31309
Complete source record
{
  "id": "549f02b028db95dcbafc262aff1e175eca044dc175ba6d1d357a92991ea22a68",
  "url": "https://osv.dev/vulnerability/CVE-2024-31309",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Traffic Server: HTTP/2 CONTINUATION frames can be utilized for DoS attack",
    "summary": "HTTP/2 CONTINUATION DoS attack can cause Apache Traffic Server to consume more resources on the server. Version from 8.0.0 through 8.1.9, from 9.0.0 through 9.2.3 are affected. Users can set a new setting (proxy.config.http2.max_continuation_frames_per_minute) to limit the number of CONTINUATION frames per minute. ATS does have a fixed amount of memory a request can use and ATS adheres to these limits in previous releases. Users are recommended to upgrade to versions 8.1.10 or 9.2.4 which fixes the issue.",
    "evidence": "osv:CVE-2024-31309",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2024-31309",
      "aliases": [
        "CVE-2024-31309"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/trafficserver",
              "type": "GIT",
              "events": [
                {
                  "introduced": "b310e3566f58dd04ec2b15b111ec86ea70e20019"
                },
                {
                  "fixed": "10bcf264100911987463c5e1cf42998ed257c231"
                },
                {
                  "introduced": "b14030656330ed623cd1f9efe2f4f9abd9d16e29"
                },
                {
                  "fixed": "90fbf13db0858cef0e0a094f445d846b60a4c1ef"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "8.0.0"
                      },
                      {
                        "fixed": "8.1.10"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "9.0.0"
                      },
                      {
                        "fixed": "9.2.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "8.1.9-rc0",
            "8.1.9",
            "8.1.8",
            "8.1.8-rc0",
            "8.1.7-rc0",
            "8.1.7",
            "8.1.6-rc0",
            "8.1.6",
            "8.1.5-rc0",
            "8.1.5",
            "8.1.4-rc0",
            "8.1.4",
            "8.1.3-rc1",
            "8.1.3",
            "8.1.3-rc0",
            "8.1.2-rc0",
            "8.1.1-rc0",
            "8.1.1",
            "8.1.0-rc0",
            "8.1.0",
            "8.0.6-rc1",
            "8.0.6",
            "8.0.6-rc0",
            "8.0.5",
            "8.0.4",
            "8.0.4-rc0",
            "8.0.3-rc0",
            "8.0.3",
            "8.0.2-rc0",
            "8.0.2",
            "8.0.1-rc0",
            "8.0.1",
            "8.0.0-rc4",
            "8.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-31309.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:38.298334944Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2024/04/msg00021.html",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PBKLPQ6ECG4PGEPRCYI3Y3OITNDEFCCV/",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QV77HYM7ARSTL3B6U3IFG7PHDU65WL4I/",
        "https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T3XON6RM5ZKCZ6K6NB7BOTAWMJQKXJDO/",
        "https://www.kb.cert.org/vuls/id/421644",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31309.json",
        "https://lists.apache.org/thread/f9qh3g3jvy153wh82pz4onrfj1wh13kc",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-31309"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-20"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0.0"
                  },
                  {
                    "last_affected": "8.1.9"
                  },
                  {
                    "introduced": "9.0.0"
                  },
                  {
                    "last_affected": "9.2.3"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/31xxx/CVE-2024-31309.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-31309",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 505815,
  "published_at": "2024-04-10T12:07:16.975+00:00"
}