Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2016-4029

WordPress before 4.5 does not consider octal and hexadecimal IP address formats when determining an intranet address, which allows remote attackers to bypass an intended SSRF protection mechanism via a crafted address.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2016-4029
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 08:05 UTC · Revision 1

Source evidence

CVE-2016-4029

core-osv · Original source

Published 7 Aug 2016, 16:59 UTC

WordPress before 4.5 does not consider octal and hexadecimal IP address formats when determining an intranet address, which allows remote attackers to bypass an intended SSRF protection mechanism via a crafted address.

osv:CVE-2016-4029
Complete source record
{
  "id": "d8d36d76fadde5b26d2edccaf3810b4f2b1982d45c7158501ba3dd0e9e23be76",
  "url": "https://osv.dev/vulnerability/CVE-2016-4029",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2016-4029",
    "summary": "WordPress before 4.5 does not consider octal and hexadecimal IP address formats when determining an intranet address, which allows remote attackers to bypass an intended SSRF protection mechanism via a crafted address.",
    "evidence": "osv:CVE-2016-4029",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2016-4029",
      "aliases": [
        "CVE-2016-4029"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "e3aafee3f2bc07e09bf79389f20ea3db731466c3"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-4029.json"
          }
        },
        {
          "ranges": [
            {
              "repo": "https://github.com/wordpress/wordpress-develop",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "7acf453090c10537e6f41fc4cf2608d7bbcce8ca"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "4.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-4029.json"
          }
        }
      ],
      "modified": "2026-10-24T10:31:02.716419502Z",
      "provider": "osv",
      "references": [
        "https://wpvulndb.com/vulnerabilities/8473",
        "https://core.trac.wordpress.org/query?status=closed&milestone=4.5"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*"
            ],
            "vendor_product": "debian:debian_linux",
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "8.0"
                  },
                  {
                    "last_affected": "8.0"
                  }
                ],
                "source": "CPE_STRING"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2016-4029",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 440077,
  "published_at": "2016-08-07T16:59:00.143+00:00"
}