phpMyFAQ SQL injections at insertentry & saveentry
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-28107
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 15:00 UTC · Revision 1
Source evidence
phpMyFAQ SQL injections at insertentry & saveentry
core-osv · Original sourcePublished 25 Mar 2024, 18:47 UTC
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.
osv:CVE-2024-28107
Complete source record
{
"id": "6f3edcd7fe97a5c6c6044b8bdfcafcf67284a757e9285c365ccd35c94648b12d",
"url": "https://osv.dev/vulnerability/CVE-2024-28107",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "phpMyFAQ SQL injections at insertentry & saveentry",
"summary": "phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. A SQL injection vulnerability has been discovered in the `insertentry` & `saveentry` when modifying records due to improper escaping of the email address. This allows any authenticated user with the rights to add/edit FAQ news to exploit this vulnerability to exfiltrate data, take over accounts and in some cases, even achieve RCE. This vulnerability is fixed in 3.2.6.",
"evidence": "osv:CVE-2024-28107",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-28107",
"aliases": [
"CVE-2024-28107",
"GHSA-2grw-mc9r-822r"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/thorsten/phpmyfaq",
"type": "GIT",
"events": [
{
"introduced": "ee05654763ef0f16137d3bd21ec50e2f21ffb8f8"
},
{
"fixed": "d0fae62a72615d809e6710861c1a7f67ac893007"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "3.2.5"
},
{
"last_affected": "3.2.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "d0fae62a72615d809e6710861c1a7f67ac893007"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.2.5"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-28107.json"
}
}
],
"modified": "2026-10-28T02:30:29.707774441Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/28xxx/CVE-2024-28107.json",
"https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-2grw-mc9r-822r",
"https://nvd.nist.gov/vuln/detail/CVE-2024-28107",
"https://github.com/thorsten/phpMyFAQ/commit/d0fae62a72615d809e6710861c1a7f67ac893007"
],
"provider_metadata": {
"cwe_ids": [
"CWE-89"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/28xxx/CVE-2024-28107.json"
}
},
"related_cves": [
{
"value": "CVE-2024-28107",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496612,
"published_at": "2024-03-25T18:47:12.328+00:00"
}