Skip to content
Heist/ feed
Back to feed
Unrated

mod_sed: Read/write beyond bounds

Type: advisorySources: OSV

Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-23943
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 15:57 UTC · Revision 1

Source evidence

mod_sed: Read/write beyond bounds

core-osv · Original source

Published 14 Mar 2022, 10:15 UTC

Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.

osv:CVE-2022-23943
Complete source record
{
  "id": "804b4c50a5a802e6786b04b33afcb3a5c1d22ffb4c81caef1cf6b6343ba9cfcb",
  "url": "https://osv.dev/vulnerability/CVE-2022-23943",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "mod_sed: Read/write beyond bounds",
    "summary": "Out-of-bounds Write vulnerability in mod_sed of Apache HTTP Server allows an attacker to overwrite heap memory with possibly attacker provided data. This issue affects Apache HTTP Server 2.4 version 2.4.52 and prior versions.",
    "evidence": "osv:CVE-2022-23943",
    "products": [],
    "severity": "unknown",
    "structured": {
      "id": "CVE-2022-23943",
      "aliases": [
        "BIT-apache-2022-23943",
        "CVE-2022-23943"
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/httpd",
              "type": "GIT",
              "events": [
                {
                  "introduced": "da5873e80d6eee7a0838793bf68f1d0254745fbb"
                },
                {
                  "fixed": "4654faee107e0c3a830c204a1dc94700705e8e86"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "2.4.0"
                      },
                      {
                        "fixed": "2.4.53"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-23943.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:36.893552929Z",
      "provider": "osv",
      "references": [
        "https://httpd.apache.org/security/vulnerabilities_24.html",
        "https://www.oracle.com/security-alerts/cpuapr2022.html",
        "https://www.tenable.com/security/tns-2022-08",
        "https://www.tenable.com/security/tns-2022-09",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23943.json",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/RGWILBORT67SHMSLYSQZG2NMXGCMPUZO/",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/X73C35MMMZGBVPQQCH7LQZUMYZNQA5FO/",
        "https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z7H26WJ6TPKNWV3QKY4BHKUKQVUTZJTD/",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-23943",
        "https://security.gentoo.org/glsa/202208-20",
        "https://security.netapp.com/advisory/ntap-20220321-0001/",
        "https://lists.debian.org/debian-lts-announce/2022/03/msg00033.html"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-190",
          "CWE-787"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "2.4"
                  },
                  {
                    "last_affected": "2.4.52"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23943.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-23943",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "core-osv",
  "document_id": 504367,
  "published_at": "2022-03-14T10:15:54+00:00"
}