AT_SECURE program buffer overflow via $ORIGIN processing
A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-95818
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 17:20 UTC · Revision 1
Source evidence
AT_SECURE program buffer overflow via $ORIGIN processing
core-osv · Original sourcePublished 22 Sept 2026, 16:50 UTC
A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.
osv:CVE-2026-95818
Complete source record
{
"id": "5579e6d623d7d2ff53fc002bac79bf902bcbd0ad25c8950be21369003416cda5",
"url": "https://osv.dev/vulnerability/CVE-2026-95818",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "AT_SECURE program buffer overflow via $ORIGIN processing",
"summary": "A stack-based buffer overflow in the dynamic loader (ld.so) of the GNU C Library (glibc) versions 2.14 through 2.44 allows a local attacker to crash or corrupt the memory of setuid/setgid (AT_SECURE) programs. When such a program's DT_RPATH or DT_RUNPATH begins with $ORIGIN and is followed by NUL or '/' the loader both reads past the end of the path buffer and writes past the end of a stack-allocated internal buffer. The corrupted loader stack can lead to a loader crash (denial of service) and limited disclosure of process memory.",
"evidence": "osv:CVE-2026-95818",
"products": [],
"severity": "low",
"structured": {
"id": "CVE-2026-95818",
"aliases": [
"CVE-2026-95818"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://sourceware.org/git/glibc.git",
"type": "GIT",
"events": [
{
"introduced": "356f8bc660a154a07b03da7c536831da5c8f74fe"
},
{
"last_affected": "c3a3a9808ad3ab4a3336836833f83288b672ccbf"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.14"
},
{
"last_affected": "2.44"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"glibc-2.44",
"glibc-2.43.9000",
"glibc-2.43",
"glibc-2.42",
"glibc-2.42.9000",
"glibc-2.41.9000",
"glibc-2.41",
"glibc-2.40",
"glibc-2.40.9000",
"glibc-2.39.9000",
"glibc-2.39",
"glibc-2.38",
"glibc-2.38.9000",
"glibc-2.37",
"glibc-2.37.9000",
"glibc-2.36",
"glibc-2.36.9000",
"glibc-2.35",
"glibc-2.35.9000",
"glibc-2.34",
"glibc-2.34.9000",
"glibc-2.33",
"glibc-2.33.9000",
"glibc-2.32",
"glibc-2.32.9000",
"glibc-2.31",
"glibc-2.31.9000",
"changelog-ends-here",
"glibc-2.30",
"glibc-2.30.9000",
"glibc-2.29",
"glibc-2.29.9000",
"glibc-2.28",
"glibc-2.28.9000",
"glibc-2.27",
"glibc-2.27.9000",
"glibc-2.26",
"glibc-2.26.9000",
"glibc-2.25",
"glibc-2.25.90",
"glibc-2.24",
"glibc-2.24.90",
"glibc-2.23",
"glibc-2.23.90",
"glibc-2.22",
"glibc-2.22.90",
"glibc-2.21",
"glibc-2.21.90",
"glibc-2.20",
"glibc-2.20.90",
"glibc-2.19",
"glibc-2.19.90",
"glibc-2.18",
"glibc-2.18.90",
"glibc-2.17",
"glibc-2.17.90",
"glibc-2.16.0",
"glibc-2.16.90",
"glibc-2.16-ports-merge",
"glibc-2.16",
"glibc-2.16-tps",
"glibc-2.15",
"glibc-2.14.9000",
"glibc-2.14"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-95818.json"
}
}
],
"modified": "2026-10-28T02:30:37.815839088Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/95xxx/CVE-2026-95818.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-95818",
"https://sourceware.org/git/?p=glibc.git;a=blob_plain;f=advisories/GLIBC-SA-2026-0023",
"https://sourceware.org/bugzilla/show_bug.cgi?id=34360"
],
"provider_metadata": {
"cwe_ids": [
"CWE-121"
],
"cna_assigner": "glibc",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.14"
},
{
"fixed": "2.45"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/95xxx/CVE-2026-95818.json"
}
},
"related_cves": [
{
"value": "CVE-2026-95818",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 505275,
"published_at": "2026-09-22T16:50:07.239+00:00"
}