CodeWhale before 0.8.64 Remote Code Execution via allow_shell
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-75911
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 8 Nov 2026, 02:43 UTC · Revision 1
Source evidence
CodeWhale before 0.8.64 Remote Code Execution via allow_shell
core-osv · Original sourcePublished 18 Aug 2026, 15:21 UTC
CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.
osv:CVE-2026-75911
Complete source record
{
"id": "d0c1a35557a317fbba33d2b95dcd5d7a0eb1337b44807743affdde07b9bd8eec",
"url": "https://osv.dev/vulnerability/CVE-2026-75911",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CodeWhale before 0.8.64 Remote Code Execution via allow_shell",
"summary": "CodeWhale versions before 0.8.64 fail to properly validate the allow_shell configuration parameter from project config files, allowing attackers to enable arbitrary shell command execution by committing a malicious .codewhale/config.toml file to a repository. When a user clones and opens the repository in CodeWhale, the AI model gains access to exec_shell and task_shell tools, enabling execution of arbitrary shell commands on the victim's machine without explicit user consent.",
"evidence": "osv:CVE-2026-75911",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-75911",
"aliases": [
"CVE-2026-75911",
"GHSA-gx45-xrj5-g6c4"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/codewhale-hq/Codewhale",
"type": "GIT",
"events": [
{
"introduced": "7125172f678dc25f3cb37ca7eab61249ef6906e7"
},
{
"fixed": "5fa24733e9a1d11315506309b8edb0fdf2b94f04"
},
{
"introduced": "5fa24733e9a1d11315506309b8edb0fdf2b94f04"
},
{
"fixed": "9d2e6a89f58610d5f426ff26533a2bf312023790"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0.8.6"
},
{
"fixed": "0.8.41"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "0.8.41"
},
{
"fixed": "0.8.64"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
}
],
"versions": [
"v0.8.40",
"v0.8.39",
"v0.8.38",
"v0.8.37",
"v0.8.36",
"v0.8.35",
"v0.8.33",
"v0.8.32",
"v0.8.31",
"v0.8.30",
"v0.8.28",
"v0.8.29",
"v0.8.27",
"v0.8.26",
"v0.8.25",
"v0.8.24",
"v0.8.23",
"v0.8.22",
"v0.8.21",
"v0.8.20",
"v0.8.19",
"v0.8.18",
"v0.8.17",
"v0.8.15",
"v0.8.14",
"v0.8.13",
"v0.8.12",
"v0.8.11",
"v0.8.10",
"v0.8.9",
"v0.8.8",
"v0.8.7",
"v0.8.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-75911.json"
}
}
],
"modified": "2026-10-28T02:30:52.788888855Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75911.json",
"https://github.com/Hmbown/CodeWhale/security/advisories/GHSA-gx45-xrj5-g6c4",
"https://nvd.nist.gov/vuln/detail/CVE-2026-75911",
"https://www.vulncheck.com/advisories/codewhale-before-remote-code-execution-via-allow-shell",
"https://github.com/Hmbown/CodeWhale/commit/43563356b98c6b993085554da82e77370160a31c"
],
"provider_metadata": {
"cwe_ids": [
"CWE-94"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75911.json"
}
},
"related_cves": [
{
"value": "CVE-2026-75911",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 521896,
"published_at": "2026-08-18T15:21:59.493+00:00"
}