Skip to content
Heist/ feed
Back to feed
CriticalFix available

Cobbler vulnerable to arbitrary code execution

Type: advisorySources: OSV

Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.

Products
cobbler
Affected versions
0.6.3-2
Fixed versions
3.0.0
CVEs
CVE-2017-1000469
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 18:46 UTC · Revision 1

Source evidence

Cobbler vulnerable to arbitrary code execution

core-osv · Original source

Published 14 May 2022, 03:49 UTC

Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.

osv:GHSA-96hw-v598-jvgh

cobbler

Fixed versions: 3.0.0

Complete source record
{
  "id": "c9280fdac8f5f8a68e08a4dbdbd01d2d23e518aa45e07d50a8e36f90513f02c9",
  "url": "https://osv.dev/vulnerability/GHSA-96hw-v598-jvgh",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Cobbler vulnerable to arbitrary code execution",
    "summary": "Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the \"add repo\" component resulting in arbitrary code execution as root user.",
    "evidence": "osv:GHSA-96hw-v598-jvgh",
    "products": [
      {
        "name": {
          "value": "cobbler",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.0.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": [
          {
            "value": "0.6.3-2",
            "evidence": "/affected/0/versions"
          }
        ]
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "GHSA-96hw-v598-jvgh",
      "aliases": [
        "CVE-2017-1000469",
        "GHSA-96hw-v598-jvgh",
        "PYSEC-2026-314"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "3.0.0"
                }
              ]
            }
          ],
          "package": {
            "name": "cobbler",
            "purl": "pkg:pypi/cobbler",
            "ecosystem": "PyPI"
          },
          "versions": [
            "0.6.3-2"
          ],
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-96hw-v598-jvgh/GHSA-96hw-v598-jvgh.json",
            "last_known_affected_version_range": "<= 2.8.2"
          }
        }
      ],
      "modified": "2026-10-27T16:30:06.485593449Z",
      "provider": "osv",
      "references": [
        "https://nvd.nist.gov/vuln/detail/CVE-2017-1000469",
        "https://github.com/cobbler/cobbler/issues/1845",
        "https://github.com/cobbler/cobbler/commit/4b20397425a5d42a2d8927233654f4d7435bd4c2",
        "https://github.com/cobbler/cobbler",
        "https://github.com/pypa/advisory-database/tree/main/vulns/cobbler/PYSEC-2026-314.yaml",
        "https://pypi.org/project/cobbler"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-20"
        ],
        "severity": "CRITICAL",
        "github_reviewed": true,
        "nvd_published_at": "2018-01-03T20:29:00Z",
        "github_reviewed_at": "2023-07-26T22:26:48Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2017-1000469",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 462871,
  "published_at": "2022-05-14T03:49:57+00:00"
}