Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-48924
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 17:34 UTC · Revision 1
Source evidence
Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs
core-osv · Original sourcePublished 11 Jul 2025, 14:56 UTC
Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.
osv:CVE-2025-48924
Complete source record
{
"id": "8ccc41eac0d50bc24c052ca1ac618e4fa494ded32ae1a5a09d433de359617d48",
"url": "https://osv.dev/vulnerability/CVE-2025-48924",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Commons Lang, Apache Commons Lang: ClassUtils.getClass(...) can throw a StackOverflowError on very long inputs",
"summary": "Uncontrolled Recursion vulnerability in Apache Commons Lang. This issue affects Apache Commons Lang: Starting with commons-lang:commons-lang 2.0 to 2.6, and, from org.apache.commons:commons-lang3 3.0 before 3.18.0. The methods ClassUtils.getClass(...) can throw StackOverflowError on very long inputs. Because an Error is usually not handled by applications and libraries, a StackOverflowError could cause an application to stop. Users are recommended to upgrade to version 3.18.0, which fixes the issue.",
"evidence": "osv:CVE-2025-48924",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2025-48924",
"aliases": [
"CVE-2025-48924",
"GHSA-j288-q9x7-2f5v"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/commons-lang",
"type": "GIT",
"events": [
{
"introduced": "da5d64110a8b7182d04359958f40fadfbe1ed6ff"
},
{
"fixed": "631f3ce18ed9ae276b34105592a13f32df200260"
},
{
"introduced": "c21484b730221bc87ca26553155350292aa30f0d"
},
{
"fixed": "5b59487808d0b86a94ad7a1ebd4c200e09b7be09"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:commons_lang:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "2.0"
},
{
"fixed": "2.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:apache:commons_lang:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.0"
},
{
"fixed": "3.18.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-48924.json"
}
}
],
"modified": "2026-10-28T02:30:51.287016889Z",
"provider": "osv",
"references": [
"https://lists.debian.org/debian-lts-announce/2025/08/msg00000.html",
"https://lists.debian.org/debian-lts-announce/2025/08/msg00026.html",
"https://lists.debian.org/debian-lts-announce/2025/09/msg00032.html",
"https://lists.debian.org/debian-lts-announce/2025/09/msg00036.html",
"https://repo.maven.apache.org/maven2",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48924.json",
"https://lists.apache.org/thread/bgv0lpswokgol11tloxnjfzdl7yrc1g1",
"https://nvd.nist.gov/vuln/detail/CVE-2025-48924"
],
"provider_metadata": {
"cwe_ids": [
"CWE-674"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.0"
},
{
"last_affected": "2.6"
},
{
"introduced": "3.0"
},
{
"fixed": "3.18.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/48xxx/CVE-2025-48924.json"
}
},
"related_cves": [
{
"value": "CVE-2025-48924",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 519998,
"published_at": "2025-07-11T14:56:58.049+00:00"
}