High
Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed
Type: advisorySources: OSV
Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-103277
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 01:19 UTC · Revision 1
Source evidence
Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed
core-osv · Original sourcePublished 1 Oct 2026, 10:42 UTC
Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.
osv:CVE-2026-103277
Complete source record
{
"id": "094c3f0c4bf67651491f3a1800f4ddf014c82d168d52eb84df6012d74ff7e155",
"url": "https://osv.dev/vulnerability/CVE-2026-103277",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Ghost 2.5.0 before 6.34.0 Untrusted Script Execution via oEmbed",
"summary": "Ghost versions from 2.5.0 before 6.34.0 contain an untrusted script execution vulnerability in the oEmbed preview feature that fails to sandbox externally hosted scripts. Attackers can craft malicious oEmbed content to execute scripts in the context of a staff user's admin session, potentially compromising administrative access.",
"evidence": "osv:CVE-2026-103277",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-103277",
"aliases": [
"BIT-ghost-2026-103277",
"CVE-2026-103277",
"GHSA-8vhf-xxpj-4qrg"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/tryghost/ghost",
"type": "GIT",
"events": [
{
"introduced": "41b23dceb7aa1166e8e05bdd61a066eee6e4aec3"
},
{
"fixed": "10da09186253d7be24698d3a5512c7f9cbea13a4"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.5.0"
},
{
"fixed": "6.34.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "2.5.0"
},
{
"fixed": "6.34.0"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-103277.json"
}
}
],
"modified": "2026-10-28T02:30:41.270082802Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/103xxx/CVE-2026-103277.json",
"https://github.com/TryGhost/Ghost/security/advisories/GHSA-8vhf-xxpj-4qrg",
"https://nvd.nist.gov/vuln/detail/CVE-2026-103277",
"https://www.vulncheck.com/advisories/ghost-2.5.0-before-6.34.0-untrusted-script-execution-via-oembed"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/103xxx/CVE-2026-103277.json"
}
},
"related_cves": [
{
"value": "CVE-2026-103277",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 508999,
"published_at": "2026-10-01T10:42:14.602+00:00"
}