Skip to content
Heist/ feed
Back to feed
High

vLLM - Denial of Service via Unvalidated Multimodal Embeddings

Type: advisorySources: OSV

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-56340
Confirmed fixed CVEs
Not specified
Updated in this feed
5 Nov 2026, 04:00 UTC · Revision 1

Source evidence

vLLM - Denial of Service via Unvalidated Multimodal Embeddings

core-osv · Original source

Published 20 Jun 2026, 18:27 UTC

vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.

osv:CVE-2026-56340
Complete source record
{
  "id": "d8d1f9f6d39f82e46ec59d4f491cedc0f805cb89439974a7604dfc575b0e2894",
  "url": "https://osv.dev/vulnerability/CVE-2026-56340",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "vLLM - Denial of Service via Unvalidated Multimodal Embeddings",
    "summary": "vLLM versions >= 0.10.2 and < 0.13.0 are missing sparse tensor validation in multimodal embeddings processing. Because PyTorch disables sparse tensor invariant checks by default, an attacker can submit crafted embedding requests with malformed (negative or out-of-bounds) tensor indices, when the prompt-embeds feature is enabled, to trigger crashes or resource exhaustion (denial of service), with potential for out-of-bounds/write-what-where memory corruption. This continues CVE-2025-62164, whose prior fix only disabled the feature by default rather than addressing the root cause.",
    "evidence": "osv:CVE-2026-56340",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-56340",
      "aliases": [
        "CVE-2026-56340",
        "GHSA-mcmc-2m55-j8jj",
        "PYSEC-2026-250"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/vllm-project/vllm",
              "type": "GIT",
              "events": [
                {
                  "introduced": "01efc7ef781391e744ed08c3292817a773d654e6"
                },
                {
                  "fixed": "72506c98349d6bcd32b4e33eec7b5513453c1502"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.10.2"
                      },
                      {
                        "fixed": "0.13.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                  },
                  {
                    "cpe": "cpe:2.3:a:vllm:vllm:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.10.2"
                      },
                      {
                        "fixed": "0.13.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-56340.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:42.134806802Z",
      "provider": "osv",
      "references": [
        "https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-56340.json",
        "https://access.redhat.com/security/cve/CVE-2026-56340",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/56xxx/CVE-2026-56340.json",
        "https://github.com/vllm-project/vllm/security/advisories/GHSA-mcmc-2m55-j8jj",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-56340",
        "https://www.vulncheck.com/advisories/vllm-denial-of-service-via-unvalidated-multimodal-embeddings",
        "https://bugzilla.redhat.com/show_bug.cgi?id=2491060"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-20"
        ],
        "cna_assigner": "VulnCheck",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/56xxx/CVE-2026-56340.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-56340",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 510077,
  "published_at": "2026-06-20T18:27:10.148+00:00"
}