Skip to content
Heist/ feed
Back to feed
MediumFix available

phpmyadmin — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-19968

An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.

Products
phpmyadmin
Affected versions
Not specified
Fixed versions
4:4.9.1+dfsg1-2
CVEs
CVE-2018-19968
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:48 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-19968

core-osv · Original source

Published 11 Dec 2018, 17:29 UTC

An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.

osv:DEBIAN-CVE-2018-19968

phpmyadmin

Fixed versions: 4:4.9.1+dfsg1-2

phpmyadmin

Fixed versions: 4:4.9.1+dfsg1-2

phpmyadmin

Fixed versions: 4:4.9.1+dfsg1-2

Complete source record
{
  "id": "0ac5c7eeebeabb50a0e5469fd03cc20a2403957c96d4931f518e7c3c0b7dcf1f",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-19968",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-19968",
    "summary": "An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.",
    "evidence": "osv:DEBIAN-CVE-2018-19968",
    "products": [
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.9.1+dfsg1-2",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.9.1+dfsg1-2",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "phpmyadmin",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4:4.9.1+dfsg1-2",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-19968",
      "aliases": [
        "DEBIAN-CVE-2018-19968"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.9.1+dfsg1-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-19968.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.9.1+dfsg1-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-19968.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4:4.9.1+dfsg1-2"
                }
              ]
            }
          ],
          "package": {
            "name": "phpmyadmin",
            "purl": "pkg:deb/debian/phpmyadmin?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-19968.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:47.915955042Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-19968"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-19968"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-19968",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 422270,
  "published_at": "2018-12-11T17:29:00.227+00:00"
}