Skip to content
Heist/ feed
Back to feed
High

CodeIgniter is vulnerable to IP address spoofing when using proxy

Type: advisorySources: OSV

CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-23556
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 19:02 UTC · Revision 1

Source evidence

CodeIgniter is vulnerable to IP address spoofing when using proxy

core-osv · Original source

Published 22 Dec 2022, 18:50 UTC

CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.

osv:CVE-2022-23556
Complete source record
{
  "id": "49cc2d278540e0d51c0d15bc347a455089b003c45cb53502a09faefe8173f406",
  "url": "https://osv.dev/vulnerability/CVE-2022-23556",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CodeIgniter is vulnerable to IP address spoofing when using proxy",
    "summary": "CodeIgniter is a PHP full-stack web framework. This vulnerability may allow attackers to spoof their IP address when the server is behind a reverse proxy. This issue has been patched, please upgrade to version 4.2.11 or later, and configure `Config\\App::$proxyIPs`. As a workaround, do not use `$request->getIPAddress()`.",
    "evidence": "osv:CVE-2022-23556",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-23556",
      "aliases": [
        "BIT-codeigniter-2022-23556",
        "CVE-2022-23556",
        "GHSA-ghw3-5qvm-3mqc"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/codeigniter4/codeigniter4",
              "type": "GIT",
              "events": [
                {
                  "introduced": "47dbb16bb5e5784f45bf09a7380016f2d36f7c39"
                },
                {
                  "fixed": "f04c67d7a1eb2ef909f916a24f614090c4bf168c"
                },
                {
                  "fixed": "5ca8c99b2db09a2a08a013836628028ddc984659"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:codeigniter:codeigniter:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "4.0.0"
                      },
                      {
                        "fixed": "4.2.11"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "5ca8c99b2db09a2a08a013836628028ddc984659"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v4.2.10",
            "v4.2.9",
            "v4.2.7",
            "v4.2.6",
            "v4.2.5",
            "v4.2.4",
            "v4.2.3",
            "v4.2.2",
            "v4.2.1",
            "v4.2.0",
            "v4.1.9",
            "v4.1.8",
            "v4.1.7",
            "v4.1.6",
            "v4.1.5",
            "v4.1.4",
            "v4.1.3",
            "v4.1.2",
            "v4.1.1",
            "v4.1.0",
            "v4.0.5",
            "v4.0.3",
            "4.0.0",
            "v4.0.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-23556.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:51.528299158Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23556.json",
        "https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-ghw3-5qvm-3mqc",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-23556",
        "https://github.com/codeigniter4/CodeIgniter4/commit/5ca8c99b2db09a2a08a013836628028ddc984659"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-345"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/23xxx/CVE-2022-23556.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-23556",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 520173,
  "published_at": "2022-12-22T18:50:55.443+00:00"
}