Skip to content
Heist/ feed
Back to feed
Low

Security advisory

Type: advisorySources: OSVCVE: CVE-2020-36828

A vulnerability was found in DiscuzX up to 3.4-20200818. It has been classified as problematic. Affected is the function show_next_step of the file upload/install/include/install_function.php. The manipulation of the argument uchidden leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.4-20210119 is able to address this issue. The name of the patch is 4a9673624f46f7609486778ded9653733020c567. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258612.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2020-36828
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:29 UTC · Revision 1

Source evidence

CVE-2020-36828

core-osv · Original source

Published 31 Mar 2024, 09:15 UTC

A vulnerability was found in DiscuzX up to 3.4-20200818. It has been classified as problematic. Affected is the function show_next_step of the file upload/install/include/install_function.php. The manipulation of the argument uchidden leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.4-20210119 is able to address this issue. The name of the patch is 4a9673624f46f7609486778ded9653733020c567. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258612.

osv:CVE-2020-36828
Complete source record
{
  "id": "6d33dd72e8fa309b7726630f6b1b4aba10a022a89efca61d90de6650e353c3e7",
  "url": "https://osv.dev/vulnerability/CVE-2020-36828",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2020-36828",
    "summary": "A vulnerability was found in DiscuzX up to 3.4-20200818. It has been classified as problematic. Affected is the function show_next_step of the file upload/install/include/install_function.php. The manipulation of the argument uchidden leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 3.4-20210119 is able to address this issue. The name of the patch is 4a9673624f46f7609486778ded9653733020c567. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-258612.",
    "evidence": "osv:CVE-2020-36828",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2020-36828",
      "aliases": [
        "CVE-2020-36828"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/codersclub/discuzx",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "last_affected": "5fb6befb58023af9ec67ca89333cad3e89de451a"
                },
                {
                  "fixed": "4a9673624f46f7609486778ded9653733020c567"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "last_affected": "3.4-20200818"
                      }
                    ],
                    "source": "DESCRIPTION"
                  },
                  {
                    "range": [
                      {
                        "fixed": "4a9673624f46f7609486778ded9653733020c567"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.4-20191201",
            "v3.4-20190917"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-36828.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:21.962907442Z",
      "provider": "osv",
      "references": [
        "https://vuldb.com/?ctiid.258612",
        "https://vuldb.com/?id.258612",
        "https://github.com/codersclub/DiscuzX/commit/4a9673624f46f7609486778ded9653733020c567"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2020-36828",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385202,
  "published_at": "2024-03-31T09:15:10.73+00:00"
}