High
yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input
Type: advisorySources: OSV
`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-41922
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 20:45 UTC · Revision 1
Source evidence
yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input
core-osv · Original sourcePublished 23 Nov 2022, 00:00 UTC
`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.
osv:CVE-2022-41922
Complete source record
{
"id": "0d7eee2c30d9aa1db871dfed580869ed36a917645cfad90f5f4ff634ca1d8797",
"url": "https://osv.dev/vulnerability/CVE-2022-41922",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input",
"summary": "`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.",
"evidence": "osv:CVE-2022-41922",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-41922",
"aliases": [
"CVE-2022-41922",
"GHSA-442f-wcwq-fpcf"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/yiisoft/yii",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "8f9404aee8ffe8c869caad733a1ce1170cdc6ad4"
},
{
"fixed": "ed67b7cc57216557c5c595c6650cdd2d3aa41c52"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.1.27"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "ed67b7cc57216557c5c595c6650cdd2d3aa41c52"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.1.26",
"1.1.25",
"1.1.24",
"1.1.23",
"1.1.22",
"1.1.21",
"1.1.20",
"1.1.19",
"1.1.18",
"1.1.17",
"1.1.14",
"1.1.14-rc",
"1.1.13",
"1.1.13-RC",
"1.1.12",
"1.1.11",
"1.1.10",
"1.1.9",
"1.1.8",
"1.1.7",
"1.1.4",
"1.1.3",
"1.1.0",
"1.1rc",
"1.1b",
"1.0rc",
"1.0a"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-41922.json"
}
}
],
"modified": "2026-10-28T02:30:39.254937868Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/41xxx/CVE-2022-41922.json",
"https://github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf",
"https://nvd.nist.gov/vuln/detail/CVE-2022-41922",
"https://github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52"
],
"provider_metadata": {
"cwe_ids": [
"CWE-502"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/41xxx/CVE-2022-41922.json"
}
},
"related_cves": [
{
"value": "CVE-2022-41922",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 506832,
"published_at": "2022-11-23T00:00:00+00:00"
}