CWE-470 in generator-jhipster-entity-audit when having Javers selected as Entity Audit Framework
generator-jhipster-entity-audit is a JHipster module to enable entity audit and audit log page. Prior to 5.9.1, generator-jhipster-entity-audit allows unsafe reflection when having Javers selected as Entity Audit Framework. If an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution. This vulnerability is fixed in 5.9.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-31119
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 13:58 UTC · Revision 1
Source evidence
CWE-470 in generator-jhipster-entity-audit when having Javers selected as Entity Audit Framework
core-osv · Original sourcePublished 3 Apr 2025, 19:11 UTC
generator-jhipster-entity-audit is a JHipster module to enable entity audit and audit log page. Prior to 5.9.1, generator-jhipster-entity-audit allows unsafe reflection when having Javers selected as Entity Audit Framework. If an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution. This vulnerability is fixed in 5.9.1.
osv:CVE-2025-31119
Complete source record
{
"id": "e2bfee55271de3d7e97cbfcd5173b4a08561c1f68c546e16daf8ec8ca91ab574",
"url": "https://osv.dev/vulnerability/CVE-2025-31119",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CWE-470 in generator-jhipster-entity-audit when having Javers selected as Entity Audit Framework",
"summary": "generator-jhipster-entity-audit is a JHipster module to enable entity audit and audit log page. Prior to 5.9.1, generator-jhipster-entity-audit allows unsafe reflection when having Javers selected as Entity Audit Framework. If an attacker manages to place some malicious classes into the classpath and also has access to these REST interface for calling the mentioned REST endpoints, using these lines of code can lead to unintended remote code execution. This vulnerability is fixed in 5.9.1.",
"evidence": "osv:CVE-2025-31119",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2025-31119",
"aliases": [
"CVE-2025-31119",
"GHSA-7rmp-3g9f-cvq8"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/jhipster/generator-jhipster-entity-audit",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "0ff1137fc89ce6b1ff59855a2d454682f113fda2"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "5.9.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "5.9.1"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v5.9.0",
"v5.8.1",
"v5.8.0",
"v5.7.0",
"v5.6.0",
"v5.5.0",
"v5.4.0",
"v5.3.0",
"v5.2.0",
"v5.1.0",
"v5.0.0",
"v5.0.0-rc.1",
"v5.0.0-beta.1",
"v4.0.0",
"v3.3.0",
"v3.2.0",
"v3.1.1",
"v3.1.0",
"3.0.0",
"2.6.1",
"v2.6.0",
"2.6.0",
"2.5.1",
"2.5.0",
"v2.4.1",
"v2.4.0",
"v2.3.0",
"v2.2.2",
"v2.2.1",
"v2.2.0",
"v2.1.0",
"v2.0.4",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.0.7",
"1.0.6",
"1.0.5",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0.1",
"1.0.0",
"0.1.10",
"0.1.9",
"0.1.8",
"0.1.7",
"0.1.6",
"0.1.5",
"0.1.4",
"0.1.3",
"0.1.2",
"0.1.1",
"0.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-31119.json"
}
}
],
"modified": "2026-10-28T02:30:29.396385762Z",
"provider": "osv",
"references": [
"https://github.com/jhipster/generator-jhipster-entity-audit/blob/e21e83135d10c77d92203c89cb0b0063914e8fe0/generators/spring-boot-javers/templates/src/main/java/_package_/web/rest/JaversEntityAuditResource.java.ejs#L88",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/31xxx/CVE-2025-31119.json",
"https://github.com/jhipster/generator-jhipster-entity-audit/security/advisories/GHSA-7rmp-3g9f-cvq8",
"https://nvd.nist.gov/vuln/detail/CVE-2025-31119"
],
"provider_metadata": {
"cwe_ids": [
"CWE-470"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/31xxx/CVE-2025-31119.json"
}
},
"related_cves": [
{
"value": "CVE-2025-31119",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 496167,
"published_at": "2025-04-03T19:11:44.091+00:00"
}