ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2025-66567
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 11:34 UTC · Revision 1
Source evidence
ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)
core-osv · Original sourcePublished 9 Dec 2025, 01:55 UTC
The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.
osv:CVE-2025-66567
Complete source record
{
"id": "da869c4f870b62582947731ab55cc998cbc48020d6a1840cecc6a19b972b2d2b",
"url": "https://osv.dev/vulnerability/CVE-2025-66567",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ruby-saml has a SAML authentication bypass due to namespace handling (parser differential)",
"summary": "The ruby-saml library is for implementing the client side of a SAML authorization. ruby-saml versions up to and including 1.12.4 contain an authentication bypass vulnerability due to an incomplete fix for CVE-2025-25292. ReXML and Nokogiri parse XML differently, generating entirely different document structures from the same input. This allows an attacker to execute a Signature Wrapping attack. This issue is fixed in version 1.18.0.",
"evidence": "osv:CVE-2025-66567",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2025-66567",
"aliases": [
"CVE-2025-66567",
"GHSA-9v8j-x534-2fx3"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/saml-toolkits/ruby-saml",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "6a7c040049babe748ee1bb4ca13898c47189114c"
},
{
"fixed": "e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:onelogin:ruby-saml:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.18.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"v1.17.0",
"v1.12.2",
"v1.16.0",
"v1.15.0",
"v1.14.0",
"v1.12.1",
"v1.12.0",
"v1.11.0",
"v1.10.2",
"v1.10.1",
"v1.10.0",
"v1.9.0",
"v1.8.0",
"v1.7.2",
"v1.7.1",
"v1.7.0",
"v1.6.2",
"v1.6.1",
"v0.9.2",
"v1.6.0",
"1.4.3",
"1.5.0",
"1.4.2",
"1.4.1",
"1.4.0",
"1.3.1",
"v1.3.0",
"v1.2.0",
"v1.1.2",
"v1.1.1",
"v1.1.0",
"v1.0.0",
"v0.9.1",
"v0.9",
"0.8.1",
"0.8.0",
"0.7.3",
"v0.7.1",
"v0.6.0",
"v0.5.3",
"v0.5.2",
"v0.5.1",
"v0.5.0",
"v0.4.7",
"v0.4.6",
"v0.4.5",
"v0.4.4",
"v0.4.3",
"v0.4.2",
"v0.4.1",
"v0.4.0",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.1",
"v0.3.0",
"v0.2.3",
"v0.2.2",
"v0.2.1",
"v0.2.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-66567.json"
}
}
],
"modified": "2026-10-28T02:30:34.654271196Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66567.json",
"https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-9v8j-x534-2fx3",
"https://github.com/advisories/GHSA-754f-8gm6-c4r2",
"https://nvd.nist.gov/vuln/detail/CVE-2025-66567",
"https://github.com/SAML-Toolkits/ruby-saml/commit/e9c1cdbd0f9afa467b585de279db0cbd0fb8ae97"
],
"provider_metadata": {
"cwe_ids": [
"CWE-347"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/66xxx/CVE-2025-66567.json"
}
},
"related_cves": [
{
"value": "CVE-2025-66567",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 502062,
"published_at": "2025-12-09T01:55:06.296+00:00"
}