High
Security advisory
In Sangoma Asterisk through 16.28.0, 17.x and 18.x through 18.14.0, and 19.x through 19.6.0, an incoming Setup message to addons/ooh323c/src/ooq931.c with a malformed Calling or Called Party IE can cause a crash.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-37325
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 17:13 UTC · Revision 1
Source evidence
In Sangoma Asterisk through 16.28.0, 17.x and 18.x through 18.14.0, and 19.x through 19.6.0, an incoming Setup message to addons/ooh323c/src/ooq931.c with a malformed Calling or Called Party IE can cause a crash.
osv:CVE-2022-37325
Complete source record
{
"id": "9c914046c59ad17b985a816b3d2145071f45d87eaaad838cb57a7b039c4974e2",
"url": "https://osv.dev/vulnerability/CVE-2022-37325",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-37325",
"summary": "In Sangoma Asterisk through 16.28.0, 17.x and 18.x through 18.14.0, and 19.x through 19.6.0, an incoming Setup message to addons/ooh323c/src/ooq931.c with a malformed Calling or Called Party IE can cause a crash.",
"evidence": "osv:CVE-2022-37325",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-37325",
"aliases": [
"CVE-2022-37325"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/asterisk/asterisk",
"type": "GIT",
"events": [
{
"introduced": "a65908f83e2f17a3aca7eb39c8e06045aca02674"
},
{
"fixed": "dd2ebdb336f13c93f7f46ee5f1f65544f4d8ab3b"
},
{
"introduced": "2c1bba3cbec008c8ce35c78a2c79f9f207ea58bc"
},
{
"fixed": "226868d1139af566c481265ef9657a1b33aa065e"
},
{
"introduced": "de4f63b4824c91a0cd9f3d95f3b7923bec71960c"
},
{
"fixed": "4c6f3fd7847bbb6111a6e615780e62780c42f9de"
},
{
"introduced": "c6c7103efa6605a6db7ca28b4b17cd2d1c15a05c"
},
{
"last_affected": "c6c7103efa6605a6db7ca28b4b17cd2d1c15a05c"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "16.0.0"
},
{
"fixed": "16.29.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "18.0.0"
},
{
"fixed": "18.15.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "19.0.0"
},
{
"fixed": "19.7.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:sangoma:asterisk:20.0.0:*:*:*:*:*:*:*",
"range": [
{
"introduced": "20.0.0"
},
{
"last_affected": "20.0.0"
}
],
"source": "CPE_STRING"
}
]
}
}
],
"versions": [
"20.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-37325.json"
}
}
],
"modified": "2026-10-28T02:30:30.483695780Z",
"provider": "osv",
"references": [
"https://downloads.asterisk.org/pub/security/AST-2022-007.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/37xxx/CVE-2022-37325.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-37325",
"https://www.debian.org/security/2023/dsa-5358",
"https://lists.debian.org/debian-lts-announce/2023/02/msg00029.html"
],
"provider_metadata": {
"cna_assigner": "mitre",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/37xxx/CVE-2022-37325.json"
}
},
"related_cves": [
{
"value": "CVE-2022-37325",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497688,
"published_at": "2022-12-05T00:00:00+00:00"
}