Skip to content
Heist/ feed
Back to feed
Low

Apache Roller: Insufficient Session Expiration on Password Change

Type: advisorySources: OSV

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-24859
Confirmed fixed CVEs
Not specified
Updated in this feed
6 Nov 2026, 01:34 UTC · Revision 1

Source evidence

Apache Roller: Insufficient Session Expiration on Password Change

core-osv · Original source

Published 14 Apr 2025, 08:18 UTC

A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.

osv:CVE-2025-24859
Complete source record
{
  "id": "a4835cf0d956df24af1b3abebbedf3c5458b0554e176279123bcf7f43b5dc193",
  "url": "https://osv.dev/vulnerability/CVE-2025-24859",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Roller: Insufficient Session Expiration on Password Change",
    "summary": "A session management vulnerability exists in Apache Roller before version 6.1.5 where active user sessions are not properly invalidated after password changes. When a user's password is changed, either by the user themselves or by an administrator, existing sessions remain active and usable. This allows continued access to the application through old sessions even after password changes, potentially enabling unauthorized access if credentials were compromised. This issue affects Apache Roller versions up to and including 6.1.4. The vulnerability is fixed in Apache Roller 6.1.5 by implementing centralized session management that properly invalidates all active sessions when passwords are changed or users are disabled.",
    "evidence": "osv:CVE-2025-24859",
    "products": [],
    "severity": "low",
    "structured": {
      "id": "CVE-2025-24859",
      "aliases": [
        "CVE-2025-24859"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/S:N/AU:N/R:U/RE:L/U:Amber"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/roller",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "395cfa30a7b274f8540424d11404c3e7433243f8"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:roller:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "1.0"
                      },
                      {
                        "fixed": "6.1.5"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "roller_6.1.3",
            "roller-6.1.3-rc1",
            "roller-6.1.2",
            "roller-6.1.2rc1",
            "roller-6.1.1-rc2",
            "roller-6.1.0",
            "roller-6.0.1",
            "roller-6.0.0-rc-3",
            "roller-6.0.0",
            "roller-5.2.3-rc-3",
            "roller-5.2.0-final",
            "roller-5.1.2"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-24859.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:45.780775241Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24859.json",
        "https://lists.apache.org/thread/4j906k16v21kdx8hk87gl7663sw7lg7f",
        "https://lists.apache.org/thread/vxv52vdr8nhtjlj6v02w43fdvo0cxw23",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-24859"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-613"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.0.0"
                  },
                  {
                    "fixed": "6.1.5"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/24xxx/CVE-2025-24859.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-24859",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 513901,
  "published_at": "2025-04-14T08:18:54.729+00:00"
}