Skip to content
Heist/ feed
Back to feed
Medium

Packistry accepts expired access tokens

Type: advisorySources: OSV

Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-27968
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 02:24 UTC · Revision 1

Source evidence

Packistry accepts expired access tokens

core-osv · Original source

Published 26 Feb 2026, 01:57 UTC

Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.

osv:CVE-2026-27968
Complete source record
{
  "id": "f6c262c20f2ba5eb135607520ed7f59362991d625773d807fa24c928fc8ae15b",
  "url": "https://osv.dev/vulnerability/CVE-2026-27968",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Packistry accepts expired access tokens",
    "summary": "Packistry is a self-hosted Composer repository designed to handle PHP package distribution. Prior to version 0.13.0, RepositoryAwareController::authorize() verified token presence and ability, but did not enforce token expiration. As a result, an expired deploy token with the correct ability could still access repository endpoints (e.g., Composer metadata/download APIs). The fix in version 0.13.0 adds an explicit expiration check, and tests now test expired deploy tokens to ensure they are rejected.",
    "evidence": "osv:CVE-2026-27968",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-27968",
      "aliases": [
        "CVE-2026-27968",
        "GHSA-4r9m-jp53-vgmw"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/packistry/packistry",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "732789bd7d64df596b55639d079ea29ff788a251"
                },
                {
                  "fixed": "7740b48f0f4ecbe63099fb056c8a146180f8b283"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:packistryphp:packistry:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "0.13.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "7740b48f0f4ecbe63099fb056c8a146180f8b283"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.12.0",
            "v0.11.1",
            "v0.11.0",
            "v0.10.3",
            "v0.10.2",
            "v0.10.1",
            "v0.10.0",
            "v0.9.3",
            "v0.9.2",
            "v0.9.1",
            "v0.9.0",
            "v0.8.4",
            "v0.8.3",
            "v0.8.2",
            "v0.8.1",
            "v0.8.0",
            "v0.7.7",
            "v0.7.6",
            "v0.7.5",
            "v0.7.4",
            "v0.7.3",
            "v0.7.2",
            "v0.7.1",
            "v0.7.0",
            "v0.6.0",
            "v0.5.0",
            "v0.4.1",
            "v0.4.0",
            "v0.3.4",
            "v0.3.3",
            "v0.3.2",
            "v0.3.1",
            "v0.3.0",
            "v0.2.3",
            "v0.2.2",
            "v0.2.1",
            "v0.2.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-27968.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:49.246802130Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27968.json",
        "https://github.com/packistry/packistry/security/advisories/GHSA-4r9m-jp53-vgmw",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-27968",
        "https://github.com/packistry/packistry/commit/7740b48f0f4ecbe63099fb056c8a146180f8b283",
        "https://github.com/packistry/packistry/pull/276"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-287",
          "CWE-613"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/27xxx/CVE-2026-27968.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-27968",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 517337,
  "published_at": "2026-02-26T01:57:12.752+00:00"
}