Skip to content
Heist/ feed
Back to feed
MediumFix available

libcatalyst-plugin-session-perl — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2018-25052

A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.

Products
libcatalyst-plugin-session-perl
Affected versions
Not specified
Fixed versions
0.41-1
CVEs
CVE-2018-25052
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 01:33 UTC · Revision 1

Source evidence

DEBIAN-CVE-2018-25052

core-osv · Original source

Published 28 Dec 2022, 12:15 UTC

A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.

osv:DEBIAN-CVE-2018-25052

libcatalyst-plugin-session-perl

Fixed versions: 0.41-1

libcatalyst-plugin-session-perl

Fixed versions: 0.41-1

libcatalyst-plugin-session-perl

Fixed versions: 0.41-1

Complete source record
{
  "id": "c4d99437849111dfdab872d96cd25902a8f5132d1f66cd43e7d0b919d2d14c6c",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2018-25052",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2018-25052",
    "summary": "A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.",
    "evidence": "osv:DEBIAN-CVE-2018-25052",
    "products": [
      {
        "name": {
          "value": "libcatalyst-plugin-session-perl",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.41-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libcatalyst-plugin-session-perl",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.41-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "libcatalyst-plugin-session-perl",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.41-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2018-25052",
      "aliases": [
        "DEBIAN-CVE-2018-25052"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.41-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libcatalyst-plugin-session-perl",
            "purl": "pkg:deb/debian/libcatalyst-plugin-session-perl?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-25052.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.41-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libcatalyst-plugin-session-perl",
            "purl": "pkg:deb/debian/libcatalyst-plugin-session-perl?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-25052.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.41-1"
                }
              ]
            }
          ],
          "package": {
            "name": "libcatalyst-plugin-session-perl",
            "purl": "pkg:deb/debian/libcatalyst-plugin-session-perl?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2018-25052.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:04:47.896198047Z",
      "provider": "osv",
      "upstream": [
        "CVE-2018-25052"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2018-25052"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2018-25052",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 423816,
  "published_at": "2022-12-28T12:15:08.607+00:00"
}