HighFix available
bind9 — security advisory
named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via TKEY queries.
- Products
- bind9
- Affected versions
- 1:9.9.3.dfsg.P2-4ubuntu1, 1:9.9.3.dfsg.P2-4ubuntu2, 1:9.9.3.dfsg.P2-4ubuntu3, 1:9.9.5.dfsg-2, 1:9.9.5.dfsg-3, 1:9.9.5.dfsg-3ubuntu0.1, 1:9.9.5.dfsg-3ubuntu0.2, 1:9.9.5.dfsg-3ubuntu0.3
- Fixed versions
- 1:9.9.5.dfsg-3ubuntu0.4
- CVEs
- CVE-2015-5477
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 06:37 UTC · Revision 1
Source evidence
named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via TKEY queries.
osv:UBUNTU-CVE-2015-5477
bind9
Fixed versions: 1:9.9.5.dfsg-3ubuntu0.4
Complete source record
{
"id": "7749aec194d2968768cd820ab8126cdbf2a9dd973c5c6dd621e1b17f02f53826",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2015-5477",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2015-5477",
"summary": "named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of service (REQUIRE assertion failure and daemon exit) via TKEY queries.",
"evidence": "osv:UBUNTU-CVE-2015-5477",
"products": [
{
"name": {
"value": "bind9",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:9.9.5.dfsg-3ubuntu0.4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1:9.9.3.dfsg.P2-4ubuntu1",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.3.dfsg.P2-4ubuntu2",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.3.dfsg.P2-4ubuntu3",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.5.dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.5.dfsg-3",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.5.dfsg-3ubuntu0.1",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.5.dfsg-3ubuntu0.2",
"evidence": "/affected/0/versions"
},
{
"value": "1:9.9.5.dfsg-3ubuntu0.3",
"evidence": "/affected/0/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2015-5477",
"aliases": [
"UBUNTU-CVE-2015-5477"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:9.9.5.dfsg-3ubuntu0.4"
}
]
}
],
"package": {
"name": "bind9",
"purl": "pkg:deb/ubuntu/bind9?arch=source&distro=trusty",
"ecosystem": "Ubuntu:14.04:LTS"
},
"versions": [
"1:9.9.3.dfsg.P2-4ubuntu1",
"1:9.9.3.dfsg.P2-4ubuntu2",
"1:9.9.3.dfsg.P2-4ubuntu3",
"1:9.9.5.dfsg-2",
"1:9.9.5.dfsg-3",
"1:9.9.5.dfsg-3ubuntu0.1",
"1:9.9.5.dfsg-3ubuntu0.2",
"1:9.9.5.dfsg-3ubuntu0.3"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-5477.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "bind9",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "bind9-host",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "bind9utils",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "dnsutils",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "host",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "libbind9-90",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "libdns100",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "libisc95",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "libisccc90",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "libisccfg90",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "liblwres90",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
},
{
"binary_name": "lwresd",
"binary_version": "1:9.9.5.dfsg-3ubuntu0.4"
}
],
"availability": "No subscription required"
}
}
],
"modified": "2026-10-12T14:20:20.230032156Z",
"provider": "osv",
"upstream": [
"CVE-2015-5477"
],
"references": [
"https://ubuntu.com/security/CVE-2015-5477",
"https://kb.isc.org/article/AA-01272/0",
"https://ubuntu.com/security/notices/USN-2693-1",
"https://www.cve.org/CVERecord?id=CVE-2015-5477",
"https://www.cisa.gov/known-exploited-vulnerabilities-catalog"
]
},
"related_cves": [
{
"value": "CVE-2015-5477",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 299949,
"published_at": "2015-07-28T00:00:00+00:00"
}