HighFix available
PHP: Multiple Vulnerabilities — GLSA 202610-02
Type: patchSources: Gentoo GLSA
Multiple vulnerabilities in PHP were found, with the worst potentially allowing remote code execution. Users should upgrade to a listed fixed version.
- Products
- PHP
- Affected versions
- < 8.2.35, < 8.3.36, < 8.4.27, < 8.5.12
- Fixed versions
- 8.2.35, 8.3.36, 8.4.27, 8.5.12
- CVEs
- CVE-2026-109618, CVE-2026-109619
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 21:59 UTC · Revision 1
Source evidence
PHP: Multiple Vulnerabilities — GLSA 202610-02
official-gentoo-glsa · Original sourcePublished 21 Oct 2026, 00:00 UTC
Multiple vulnerabilities in PHP were found, with the worst potentially allowing remote code execution. Users should upgrade to a listed fixed version.
Multiple vulnerabilities have been found in PHP, the worst of which could result in remote code execution.
PHP
Fixed versions: 8.5.12, 8.4.27, 8.3.36, 8.2.35
Complete source record
{
"id": "8b9fe584eee16d2b957e13aa13cf697552402ede8f168bbc13e21917b770084a",
"url": "https://security.gentoo.org/glsa/202610-02",
"method": "llm",
"payload": {
"kind": "patch",
"title": "PHP: Multiple Vulnerabilities — GLSA 202610-02",
"summary": "Multiple vulnerabilities in PHP were found, with the worst potentially allowing remote code execution. Users should upgrade to a listed fixed version.",
"evidence": "Multiple vulnerabilities have been found in PHP, the worst of which could result in remote code execution.",
"products": [
{
"name": {
"value": "PHP",
"evidence": "Multiple vulnerabilities have been found in PHP"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "8.5.12",
"evidence": "All PHP 8.5 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose \">=dev-lang/php-8.5.12:8.5\""
},
{
"value": "8.4.27",
"evidence": "All PHP 8.4 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose \">=dev-lang/php-8.4.27:8.4\""
},
{
"value": "8.3.36",
"evidence": "All PHP 8.3 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose \">=dev-lang/php-8.3.36:8.3\""
},
{
"value": "8.2.35",
"evidence": "All PHP 8.2 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose \">=dev-lang/php-8.2.35:8.2\""
}
],
"affected_versions": [
{
"value": "< 8.5.12",
"evidence": "< 8.5.12"
},
{
"value": "< 8.4.27",
"evidence": "< 8.4.27"
},
{
"value": "< 8.3.36",
"evidence": "< 8.3.36"
},
{
"value": "< 8.2.35",
"evidence": "< 8.2.35"
}
]
}
],
"severity": "high",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2026-109618",
"evidence": "CVE-2026-109618"
},
{
"value": "CVE-2026-109619",
"evidence": "CVE-2026-109619"
}
],
"security_relevant": true,
"severity_evidence": "Severity high"
},
"source_id": "official-gentoo-glsa",
"document_id": 23638,
"published_at": "2026-10-21T00:00:00+00:00"
}