Medium
Security advisory
Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-42648
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:58 UTC · Revision 1
Source evidence
Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.
osv:CVE-2021-42648
Complete source record
{
"id": "db297f535efa5631e01f108472713e3d5891a18de8cddc7a7d517698db5d98da",
"url": "https://osv.dev/vulnerability/CVE-2021-42648",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-42648",
"summary": "Cross-site scripting (XSS) vulnerability exists in Coder Code-Server before 3.12.0, allows attackers to execute arbitrary code via crafted URL.",
"evidence": "osv:CVE-2021-42648",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-42648",
"aliases": [
"CVE-2021-42648",
"GHSA-2gp3-6c9p-jp7w"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/coder/code-server",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "798dc0baf284416dbbf951e4ef596beeab6cb6c4"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:coder:code-server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.12.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v3.9.1",
"3.4.1",
"3.4.0",
"v3.3.0",
"3.2.0",
"3.1.1",
"3.1.0",
"3.0.2",
"3.0.1",
"3.0.0",
"2.1698",
"2.1692-vsc1.39.2",
"2.1688-vsc1.39.2",
"2.1665-vsc1.39.2",
"2.1662-vsc1.39.2",
"2.1655-vsc1.39.2",
"2.1650-vsc1.39.2",
"2.1638-vsc1.39.2",
"2.1637-vsc1.39.2",
"2.1523-vsc1.38.1",
"2.1485-vsc1.38.1",
"2.1478-vsc1.38.1",
"2.1472-vsc1.38.1",
"1.1119-vsc1.33.1",
"1.1156-vsc1.33.1",
"1.1140-vsc1.33.1",
"1.1106-vsc1.33.1",
"1.1099-vsc1.33.1",
"1.939-vsc1.33.1",
"1.903-vsc1.33.1",
"1.868-vsc1.33.1",
"1.854-vsc1.33.1",
"1.792-vsc1.33.1",
"1.790-vsc1.33.1",
"1.696-vsc1.33.0",
"1.691-vsc1.33.0",
"1.604-vsc1.32.0",
"1.408-vsc1.32.0",
"1.32.0-310",
"1.32.0-282",
"1.32.0-275",
"1.32.0-245",
"1.31.1-100",
"1.31.0-20",
"1.31.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-42648.json"
}
}
],
"modified": "2026-10-20T10:55:00.864181289Z",
"provider": "osv",
"references": [
"https://github.com/cdr/code-server/issues/4355"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-42648",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 386683,
"published_at": "2022-05-11T18:15:23.097+00:00"
}