multer vulnerable to Denial of Service via deeply nested field names
Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-5079
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 03:05 UTC · Revision 1
Source evidence
multer vulnerable to Denial of Service via deeply nested field names
core-osv · Original sourcePublished 15 Jun 2026, 13:56 UTC
Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
osv:CVE-2026-5079
Complete source record
{
"id": "4f293b499cca39301cf2b1fe164cd258b8f7c3a054fb72c0d121a7755f23cfad",
"url": "https://osv.dev/vulnerability/CVE-2026-5079",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "multer vulnerable to Denial of Service via deeply nested field names",
"summary": "Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this. Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires. Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.",
"evidence": "osv:CVE-2026-5079",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-5079",
"aliases": [
"CVE-2026-5079",
"GHSA-72gw-mp4g-v24j"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/expressjs/multer",
"type": "GIT",
"events": [
{
"introduced": "869e2138af1d2b9cf62b8abb95e5785aef007b4b"
},
{
"fixed": "2e2af08157c66cbbc76539ccbd8869097a0c8feb"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:expressjs:multer:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "1.0.0"
},
{
"fixed": "2.2.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.1.1",
"v2.1.0",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.4.5-lts.2",
"v1.4.5-lts.1",
"v1.4.4",
"v1.4.4-lts.1",
"v1.4.3",
"v1.4.2",
"v1.4.1",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.2.1",
"v1.2.0",
"v1.1.0",
"v1.0.6",
"v1.0.5",
"v1.0.4",
"v1.0.3",
"v1.0.2",
"v1.0.1",
"v1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-5079.json"
}
}
],
"modified": "2026-10-28T02:30:33.054283765Z",
"provider": "osv",
"references": [
"https://cna.openjsf.org/security-advisories.html",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/5xxx/CVE-2026-5079.json",
"https://github.com/expressjs/multer/security/advisories/GHSA-72gw-mp4g-v24j",
"https://nvd.nist.gov/vuln/detail/CVE-2026-5079"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "openjs",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/5xxx/CVE-2026-5079.json"
}
},
"related_cves": [
{
"value": "CVE-2026-5079",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 499881,
"published_at": "2026-06-15T13:56:45.52+00:00"
}