LowFix available
linux — security advisory
drivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.
- Products
- linux
- Affected versions
- Not specified
- Fixed versions
- 5.17.6-1
- CVEs
- CVE-2022-33981
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 15:01 UTC · Revision 1
Source evidence
drivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.
osv:DEBIAN-CVE-2022-33981
linux
Fixed versions: 5.17.6-1
linux
Fixed versions: 5.17.6-1
linux
Fixed versions: 5.17.6-1
Complete source record
{
"id": "8de9c460f54aa0ee3ea97cb4e9f4f31ff88246bbf164eb6d96df90fcd4f0d477",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-33981",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-33981",
"summary": "drivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.",
"evidence": "osv:DEBIAN-CVE-2022-33981",
"products": [
{
"name": {
"value": "linux",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.17.6-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linux",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.17.6-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "linux",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.17.6-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "low",
"structured": {
"id": "DEBIAN-CVE-2022-33981",
"aliases": [
"DEBIAN-CVE-2022-33981"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.17.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33981.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.17.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33981.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.17.6-1"
}
]
}
],
"package": {
"name": "linux",
"purl": "pkg:deb/debian/linux?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33981.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:44.015800733Z",
"provider": "osv",
"upstream": [
"CVE-2022-33981"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-33981"
]
},
"related_cves": [
{
"value": "CVE-2022-33981",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 324087,
"published_at": "2022-06-18T16:15:08.227+00:00"
}