Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer
Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-4350
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 03:27 UTC · Revision 1
Source evidence
Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer
core-osv · Original sourcePublished 9 Aug 2024, 00:37 UTC
Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)
osv:CVE-2024-4350
Complete source record
{
"id": "8dc2708c3da27c5024149f65434de218ac40be42cec1b084f4f381bb47a5e03c",
"url": "https://osv.dev/vulnerability/CVE-2024-4350",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Concrete CMS version 9 below 9.3.3 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer",
"summary": "Concrete CMS versions 9.0.0 to 9.3.2 and below 8.5.18 are vulnerable to Stored XSS in RSS Displayer when user input is stored and later embedded into responses. A rogue administrator could inject malicious code into fields due to insufficient input validation. The Concrete CMS security team gave this vulnerability a CVSS v4 score of 5.1 with vector https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N Thanks, m3dium for reporting. (CNA updated this risk rank on 17 Jan 2025 by lowering the AC based on CVSS 4.0 documentation that access privileges should not be considered for AC)",
"evidence": "osv:CVE-2024-4350",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-4350",
"aliases": [
"CVE-2024-4350",
"GHSA-q5wx-m95r-4cgc"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/concretecms/concretecms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "dd48390befb638849e3454f399964242355cf28b"
},
{
"introduced": "b3774abddd475b4ba98b637402506f7a5ebd90ea"
},
{
"fixed": "52c835aece7bdbfa3d4592ceab4fe64d5259438b"
},
{
"fixed": "c08d9671cec4e7afdabb547339c4bc0bed8eab06"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "8.5.18"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:concretecms:concrete_cms:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "9.0.0"
},
{
"fixed": "9.3.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "c08d9671cec4e7afdabb547339c4bc0bed8eab06"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"9.3.0",
"9.3.2",
"8.5.17",
"9.3.1",
"8.5.16",
"8.5.15",
"8.5.14",
"8.5.13",
"8.5.9",
"8.5.7",
"8.5.6",
"8.4.1",
"8.3.1",
"8.2.1",
"8.2.0",
"8.2.0RC2",
"8.1.0",
"5.7.5.7",
"5.7.5.6",
"5.7.5.5",
"5.7.5.2",
"5.7.4.1",
"5.7.3.1",
"5.7.3",
"5.7.2.1",
"5.7.2",
"5.7.0.4",
"5.7.1",
"5.7.0.3",
"5.7.0.1",
"5.7.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-4350.json"
}
}
],
"modified": "2026-10-28T02:30:42.257574488Z",
"provider": "osv",
"references": [
"https://documentation.concretecms.org/9-x/developers/introduction/version-history/933-release-notes?pk_vid=e367a434ef4830491723060415d52041",
"https://documentation.concretecms.org/developers/introduction/version-history/8518-release-notes?pk_vid=e367a434ef4830491723055758d52041",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4350.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-4350",
"https://github.com/concretecms/concretecms/commit/c08d9671cec4e7afdabb547339c4bc0bed8eab06",
"https://github.com/concretecms/concretecms/pull/12166",
"https://github.com/concretecms/concretecms"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "ConcreteCMS",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/4xxx/CVE-2024-4350.json"
}
},
"related_cves": [
{
"value": "CVE-2024-4350",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 509844,
"published_at": "2024-08-09T00:37:44.009+00:00"
}