MediumFix available
blender — security advisory
An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
- Products
- blender
- Affected versions
- Not specified
- Fixed versions
- 3.1.2+dfsg-1
- CVEs
- CVE-2022-0544
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 14:53 UTC · Revision 1
Source evidence
An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.
osv:DEBIAN-CVE-2022-0544
blender
Fixed versions: 3.1.2+dfsg-1
blender
Fixed versions: 3.1.2+dfsg-1
Complete source record
{
"id": "99ef1bb47d63697c5e37a63bda7d81b831e79d645e88915221244d40d8e01893",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-0544",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-0544",
"summary": "An integer underflow in the DDS loader of Blender leads to an out-of-bounds read, possibly allowing an attacker to read sensitive data using a crafted DDS image file. This flaw affects Blender versions prior to 2.83.19, 2.93.8 and 3.1.",
"evidence": "osv:DEBIAN-CVE-2022-0544",
"products": [
{
"name": {
"value": "blender",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.1.2+dfsg-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "blender",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.1.2+dfsg-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2022-0544",
"aliases": [
"DEBIAN-CVE-2022-0544"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.2+dfsg-1"
}
]
}
],
"package": {
"name": "blender",
"purl": "pkg:deb/debian/blender?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-0544.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.1.2+dfsg-1"
}
]
}
],
"package": {
"name": "blender",
"purl": "pkg:deb/debian/blender?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-0544.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T16:01:51.579121401Z",
"provider": "osv",
"upstream": [
"CVE-2022-0544"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-0544"
]
},
"related_cves": [
{
"value": "CVE-2022-0544",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 454303,
"published_at": "2022-02-24T19:15:09.713+00:00"
}