Security advisory
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21327
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:32 UTC · Revision 1
Source evidence
GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4.
osv:CVE-2021-21327
Complete source record
{
"id": "ebc6a6ba81af48da395f2b6517049769fd30f226dd9c1156d328cf96a2ee12ed",
"url": "https://osv.dev/vulnerability/CVE-2021-21327",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21327",
"summary": "GLPI is an open-source asset and IT management software package that provides ITIL Service Desk features, licenses tracking and software auditing. In GLPI before version 9.5.4 non-authenticated user can remotely instantiate object of any class existing in the GLPI environment that can be used to carry out malicious attacks, or to start a “POP chain”. As an example of direct impact, this vulnerability affects integrity of the GLPI core platform and third-party plugins runtime misusing classes which implement some sensitive operations in their constructors or destructors. This is fixed in version 9.5.4.",
"evidence": "osv:CVE-2021-21327",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-21327",
"aliases": [
"CVE-2021-21327",
"GHSA-qmw7-w2m4-rjwp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/glpi-project/glpi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "59a0a0b6101fcd54b00bfc6a61d4e707513c08c9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:glpi-project:glpi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "9.5.4"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "59a0a0b6101fcd54b00bfc6a61d4e707513c08c9"
}
],
"source": "REFERENCES_TAG",
"original_tag": "9.5.4"
}
]
}
}
],
"versions": [
"9.5.3",
"9.5.2",
"9.5.1",
"9.5.0",
"9.5.0-rc2",
"9.5.0-rc1",
"9.4.1.1",
"9.4.1",
"9.4.0",
"9.4.0-rc2",
"9.4.0-rc1",
"9.4.0-beta",
"9.3-beta",
"9.1",
"9.1-RC2",
"9.1-RC1",
"0.90",
"0.90-RC2",
"0.90-RC1",
"0.90-beta2",
"0.90-beta1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21327.json"
}
}
],
"modified": "2026-10-20T10:54:28.243666799Z",
"provider": "osv",
"references": [
"https://github.com/glpi-project/glpi/releases/tag/9.5.4",
"https://github.com/glpi-project/glpi/security/advisories/GHSA-qmw7-w2m4-rjwp"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21327",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385411,
"published_at": "2021-03-08T17:15:13.197+00:00"
}