Skip to content
Heist/ feed
Back to feed
Medium

e107: Broken Access Control in e107 comment edit allows cross-user comment modification

Type: advisorySources: OSV

e107 is a content management system (CMS). Prior to 2.3.4, a Broken Access Control vulnerability exists in the application, allowing an unauthorized authenticated user to edit comments posted by others. This stems from inadequate server-side access control validation, where the application depends only on a predictable identifier in the request to determine which comment to edit, without confirming the requesting user’s ownership of the comment. This vulnerability is fixed in 2.3.4.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-43934
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 15:09 UTC · Revision 1

Source evidence

e107: Broken Access Control in e107 comment edit allows cross-user comment modification

core-osv · Original source

Published 26 May 2026, 14:54 UTC

e107 is a content management system (CMS). Prior to 2.3.4, a Broken Access Control vulnerability exists in the application, allowing an unauthorized authenticated user to edit comments posted by others. This stems from inadequate server-side access control validation, where the application depends only on a predictable identifier in the request to determine which comment to edit, without confirming the requesting user’s ownership of the comment. This vulnerability is fixed in 2.3.4.

osv:CVE-2026-43934
Complete source record
{
  "id": "1994e648efa58ee99f9352af54f09d5aaa8bc2b6d38fc2e15cd447d6ca138e0e",
  "url": "https://osv.dev/vulnerability/CVE-2026-43934",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "e107: Broken Access Control in e107 comment edit allows cross-user comment modification",
    "summary": "e107 is a content management system (CMS). Prior to 2.3.4, a Broken Access Control vulnerability exists in the application, allowing an unauthorized authenticated user to edit comments posted by others. This stems from inadequate server-side access control validation, where the application depends only on a predictable identifier in the request to determine which comment to edit, without confirming the requesting user’s ownership of the comment. This vulnerability is fixed in 2.3.4.",
    "evidence": "osv:CVE-2026-43934",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-43934",
      "aliases": [
        "CVE-2026-43934",
        "GHSA-5w63-63rh-99q6"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/e107inc/e107",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "009145d2ddb96407d8ed996ec0152b90254c8822"
                },
                {
                  "fixed": "23961a8f"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.3.4"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "fixed": "23961a8f"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.3.3",
            "v2.3.2",
            "v2.3.1",
            "v2.3.0",
            "v2.3.0-rc1",
            "v2.2.1",
            "v2.2.0",
            "v2.1.9",
            "v2.1.8",
            "v2.1.7",
            "v2.1.6",
            "v2.1.5",
            "v2.1.4",
            "v2.1.3",
            "v2.1.2",
            "v2.1.1",
            "v2.0-beta1",
            "v2.0alpha"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-43934.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:29.731184443Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/43xxx/CVE-2026-43934.json",
        "https://github.com/e107inc/e107/security/advisories/GHSA-5w63-63rh-99q6",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-43934",
        "https://github.com/e107inc/e107/commit/23961a8f"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-284",
          "CWE-639"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/43xxx/CVE-2026-43934.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-43934",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 496686,
  "published_at": "2026-05-26T14:54:21.21+00:00"
}