Payload vulnerable to API key disclosure through ordinary document reads
### Impact Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled. You are affected if: - An authentication collection enables `useAPIKey`. - Users have read access to other user documents containing active API keys. ### Patches Users should upgrade payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Disable `useAPIKey` or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.
- Products
- payload
- Affected versions
- Not specified
- Fixed versions
- 3.90.0, 4.0.0-canary.34
- CVEs
- CVE-2026-105849
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 27 Oct 2026, 12:15 UTC · Revision 1
Source evidence
Payload vulnerable to API key disclosure through ordinary document reads
core-osv · Original sourcePublished 6 Oct 2026, 16:18 UTC
### Impact Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled. You are affected if: - An authentication collection enables `useAPIKey`. - Users have read access to other user documents containing active API keys. ### Patches Users should upgrade payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Disable `useAPIKey` or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.
osv:GHSA-238x-w2j9-gwwr
payload
Fixed versions: 3.90.0
payload
Fixed versions: 4.0.0-canary.34
Complete source record
{
"id": "fa93982530bcecca4863e613e63ad4868d64f074c7cfc14229037b76e88cd9cf",
"url": "https://osv.dev/vulnerability/GHSA-238x-w2j9-gwwr",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Payload vulnerable to API key disclosure through ordinary document reads",
"summary": "### Impact Users with read access to other user documents could access their active API keys. An exposed key grants the target account’s permissions until rotated or disabled. You are affected if: - An authentication collection enables `useAPIKey`. - Users have read access to other user documents containing active API keys. ### Patches Users should upgrade payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds Disable `useAPIKey` or restrict users to reading only their own authentication document. Rotate any API key that may have been exposed.",
"evidence": "osv:GHSA-238x-w2j9-gwwr",
"products": [
{
"name": {
"value": "payload",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.90.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "payload",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.0-canary.34",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "GHSA-238x-w2j9-gwwr",
"aliases": [
"CVE-2026-105849",
"GHSA-238x-w2j9-gwwr"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.90.0"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-238x-w2j9-gwwr/GHSA-238x-w2j9-gwwr.json"
}
},
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "4.0.0-canary.0"
},
{
"fixed": "4.0.0-canary.34"
}
]
}
],
"package": {
"name": "payload",
"purl": "pkg:npm/payload",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-238x-w2j9-gwwr/GHSA-238x-w2j9-gwwr.json"
}
}
],
"modified": "2026-10-06T16:30:04.323819650Z",
"provider": "osv",
"references": [
"https://github.com/payloadcms/payload/security/advisories/GHSA-238x-w2j9-gwwr",
"https://github.com/payloadcms/payload/commit/880d2e900be22cd66a9e939f2b3e702fa413180f",
"https://github.com/payloadcms/payload",
"https://github.com/payloadcms/payload/releases/tag/v3.90.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-201",
"CWE-862"
],
"severity": "HIGH",
"github_reviewed": true,
"nvd_published_at": null,
"github_reviewed_at": "2026-10-06T16:18:16Z"
}
},
"related_cves": [
{
"value": "CVE-2026-105849",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 89317,
"published_at": "2026-10-06T16:18:16+00:00"
}