Skip to content
Heist/ feed
Back to feed
Medium

Security advisory

Type: advisorySources: OSVCVE: CVE-2017-20183

A vulnerability was found in External Media without Import Plugin up to 1.0.0 on WordPress. It has been declared as problematic. This vulnerability affects the function print_media_new_panel of the file external-media-without-import.php. The manipulation of the argument url/error/width/height/mime-type leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.0.1 is able to address this issue. The patch is identified as 9d2ecd159a6e2e3f710b4f1c28e2714f66502746. It is recommended to upgrade the affected component. VDB-227950 is the identifier assigned to this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2017-20183
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 09:45 UTC · Revision 1

Source evidence

CVE-2017-20183

core-osv · Original source

Published 5 May 2023, 01:15 UTC

A vulnerability was found in External Media without Import Plugin up to 1.0.0 on WordPress. It has been declared as problematic. This vulnerability affects the function print_media_new_panel of the file external-media-without-import.php. The manipulation of the argument url/error/width/height/mime-type leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.0.1 is able to address this issue. The patch is identified as 9d2ecd159a6e2e3f710b4f1c28e2714f66502746. It is recommended to upgrade the affected component. VDB-227950 is the identifier assigned to this vulnerability.

osv:CVE-2017-20183
Complete source record
{
  "id": "564c54456aaf3f07f61524212d24facb9fc43963f8b2622fbb4bcaf1a289007d",
  "url": "https://osv.dev/vulnerability/CVE-2017-20183",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2017-20183",
    "summary": "A vulnerability was found in External Media without Import Plugin up to 1.0.0 on WordPress. It has been declared as problematic. This vulnerability affects the function print_media_new_panel of the file external-media-without-import.php. The manipulation of the argument url/error/width/height/mime-type leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.0.1 is able to address this issue. The patch is identified as 9d2ecd159a6e2e3f710b4f1c28e2714f66502746. It is recommended to upgrade the affected component. VDB-227950 is the identifier assigned to this vulnerability.",
    "evidence": "osv:CVE-2017-20183",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2017-20183",
      "aliases": [
        "CVE-2017-20183"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/zzxiang/external-media-without-import",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "9d2ecd159a6e2e3f710b4f1c28e2714f66502746"
                },
                {
                  "fixed": "aa9071efa14366db4fcc36c7142b3e3e44a3e06b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "9d2ecd159a6e2e3f710b4f1c28e2714f66502746"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "aa9071efa14366db4fcc36c7142b3e3e44a3e06b"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.0.1"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-20183.json"
          }
        }
      ],
      "modified": "2026-10-20T10:47:49.350665722Z",
      "provider": "osv",
      "references": [
        "https://github.com/zzxiang/external-media-without-import/releases/tag/v1.0.1",
        "https://vuldb.com/?ctiid.227950",
        "https://vuldb.com/?id.227950",
        "https://github.com/zzxiang/external-media-without-import/commit/9d2ecd159a6e2e3f710b4f1c28e2714f66502746"
      ],
      "provider_metadata": {
        "unresolved_ranges": [
          {
            "cpes": [
              "cpe:2.3:a:external_media_without_import_project:external_media_without_import:*:*:*:*:*:*:*:*"
            ],
            "vendor_product": "external_media_without_import_project:external_media_without_import",
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.0.0"
                  }
                ],
                "source": "CPE_RANGE"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "last_affected": "1.0.0"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ]
      }
    },
    "related_cves": [
      {
        "value": "CVE-2017-20183",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 379753,
  "published_at": "2023-05-05T01:15:08.55+00:00"
}