Medium
WP ULike < 4.7.4 - Admin+ Stored XSS
Type: advisorySources: OSV
The WP ULike WordPress plugin before 4.7.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-7878
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 20:24 UTC · Revision 1
Source evidence
The WP ULike WordPress plugin before 4.7.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
osv:CVE-2024-7878
Complete source record
{
"id": "e22fa7aa3c393dcc076f09c334a3f8275c4b74ab019ba9a9a0dd5dd4a73e192a",
"url": "https://osv.dev/vulnerability/CVE-2024-7878",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WP ULike < 4.7.4 - Admin+ Stored XSS",
"summary": "The WP ULike WordPress plugin before 4.7.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).",
"evidence": "osv:CVE-2024-7878",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-7878",
"aliases": [
"CVE-2024-7878"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/alimir/wp-ulike",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "826f0c4e79dcbfa5e4410809cc39eb5802001d43"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:technowich:wp_ulike:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.7.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"4.7.2",
"4.6.8",
"4.6.7",
"4.6.1",
"4.5.5",
"4.5.1",
"4.5.0",
"4.4.9",
"4.4.8",
"4.4.7",
"4.4.6",
"4.4.5",
"4.4.3",
"4.4.2",
"4.4.1",
"4.4.0",
"4.3.6",
"4.3.3",
"4.3.2",
"4.3.1",
"4.3.0",
"4.2.6",
"4.2.5",
"4.2.4",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.9",
"4.1.8",
"4.1.7",
"4.1.6",
"4.1.5",
"4.1.4",
"4.1.3",
"4.1.2",
"4.1.1",
"4.1.0",
"4.0.5",
"4.0.4",
"4.0.3",
"4.0.2",
"4.0.0",
"3.6.2",
"3.6.1",
"v3.4",
"v3.3.1",
"v3.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-7878.json"
}
}
],
"modified": "2026-10-28T02:30:23.386275674Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/7xxx/CVE-2024-7878.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-7878",
"https://wpscan.com/vulnerability/9166cf91-69e5-4786-a6a9-816db7d47b07/"
],
"provider_metadata": {
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "4.7.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/7xxx/CVE-2024-7878.json"
}
},
"related_cves": [
{
"value": "CVE-2024-7878",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489817,
"published_at": "2024-09-25T06:00:05.377+00:00"
}