vCluster Platform: Stored XSS can lead to privilege escalation
vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-42457
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 16:55 UTC · Revision 1
Source evidence
vCluster Platform: Stored XSS can lead to privilege escalation
core-osv · Original sourcePublished 14 May 2026, 14:48 UTC
vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.
osv:CVE-2026-42457
Complete source record
{
"id": "6304a823d8368ffe30e517079c6361de505843df5b1d4f20c325511aa02e6f7f",
"url": "https://osv.dev/vulnerability/CVE-2026-42457",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "vCluster Platform: Stored XSS can lead to privilege escalation",
"summary": "vCluster Platform provides a Kubernetes platform for managing virtual clusters, multi-tenancy, and cluster sharing. Prior to 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0, there is a Stored XSS attack vulnerability via the name field of a templateRef. This can lead to the execution of arbitrary external scripts within the platform's browser context. In the worst case, a malicious user could potentially create a new Global-Admin user, bypassing other security restrictions. The attacker needs the ability to create namespaces. This vulnerability is fixed in 4.4.3, 4.5.5, 4.6.2, 4.7.1, and 4.8.0.",
"evidence": "osv:CVE-2026-42457",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2026-42457",
"aliases": [
"CVE-2026-42457",
"GHSA-x7cq-v3h6-426c"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/loft-sh/loft",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "76e6e9a0a1cc13b7d945c9809860ac3736403164"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.4.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "4.4.3"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"v4.4.3-rc.2",
"v4.0.0-alpha.6",
"v4.0.0-alpha.5",
"v4.0.0-alpha.4",
"v3.4.6",
"v3.5.0-alpha.5",
"v3.5.0-alpha.4",
"v3.4.6-rc.1",
"v4.0.0-alpha.3",
"v4.0.0-alpha.2",
"v4.0.0-alpha.1",
"v3.5.0-alpha.3",
"v4.0.0-alpha.0",
"v3.5.0-alpha.2",
"v3.4.6-beta.0",
"v3.5.0-alpha.1",
"v3.4.6-alpha.1",
"v3.5.0-alpha.0",
"v3.4.5",
"v3.4.4-beta.6",
"v3.4.4-beta.5",
"v3.4.4-beta.4",
"v3.4.4",
"v3.4.4-beta.3",
"v3.4.3-beta.2",
"v3.4.3-beta.1",
"v3.4.3",
"v3.4.3-beta.0",
"v3.4.2-beta.1",
"v3.4.2",
"v3.4.2-beta.0",
"v3.4.1-beta.0",
"v3.4.1",
"v2.0.1",
"v2.0.1-beta.0",
"v2.0.0",
"v2.0.0-rc.1",
"v2.0.0-rc.0",
"v2.0.0-beta.2",
"v2.0.0-beta.1",
"v2.0.0-beta.0",
"v2.0.0-alpha.13",
"v2.0.0-alpha.12",
"v2.0.0-alpha.11",
"v2.0.0-alpha.10",
"v2.0.0-alpha.9",
"v2.0.0-alpha.8",
"v2.0.0-alpha.7",
"v2.0.0-alpha.6",
"v2.0.0-alpha.5",
"v2.0.0-alpha.4",
"v2.0.0-alpha.2",
"v2.0.0-alpha.1",
"v2.0.0-alpha.0",
"v1.15.1-beta.0",
"v1.15.0",
"v1.15.0-rc.2",
"v1.15.0-rc.1",
"v1.15.0-beta.3",
"v1.15.0-beta.2",
"v1.15.0-beta.1",
"v1.15.0-beta.0",
"v1.15.0-alpha.1",
"v1.14.0",
"v1.14.0-beta.0",
"v1.13.1",
"v1.13.1-beta.1",
"v1.13.1-beta.0",
"v1.13.0",
"v1.13.0-alpha.5",
"v1.13.0-alpha.4",
"v1.12.2-ie11",
"v1.12.2",
"v1.12.1",
"v1.12.1-beta.7",
"v1.12.1-beta.6",
"v1.12.1-beta.2",
"v1.12.1-beta.1",
"v1.12.1-beta.0",
"v1.12.0-ie11",
"v1.12.0",
"v1.12.0-beta.1",
"v1.12.0-beta.0",
"v1.12.0-alpha.1",
"v1.12.0-alpha.0",
"v1.11.1-kubernetes.115",
"v1.11.1",
"v1.11.0",
"v1.11.0-beta.3",
"v1.11.0-beta.2",
"v1.11.0-beta.1",
"v1.11.0-beta.0",
"v1.10.2-beta.2",
"v1.10.2-beta.1",
"v1.10.2-beta.0",
"v1.10.2-alpha.0",
"v1.10.1",
"v1.10.0",
"v1.10.0-beta.1",
"v1.10.0-beta.0",
"v1.9.3-kubernetes.115",
"v1.9.3-beta.1",
"v1.9.3",
"v1.9.3-beta.0",
"v1.9.2-kubernetes.115.1",
"v1.9.2-kubernetes.115",
"v1.9.2",
"v1.9.1-kubernetes.115",
"v1.9.1-beta.1",
"v1.9.1-beta.0",
"v1.9.1",
"v1.9.0-beta.2",
"v1.9.0-beta.1",
"v1.9.0",
"v1.9.0-beta.0",
"v1.8.2-beta.1",
"v1.8.2-beta.0",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.8.0-beta.0",
"v1.7.2-beta.0",
"v1.7.2",
"v1.7.1-beta.0",
"v1.7.1",
"v1.7.0-beta.1",
"v1.7.0-beta.0",
"v1.7.0",
"v1.6.2",
"v1.6.1",
"v1.6.0-beta.0",
"v1.6.0",
"v1.5.5",
"v1.5.4",
"v1.5.3",
"v1.5.2-beta.1",
"v1.5.2-beta.0",
"v1.5.2",
"v1.5.1",
"v1.5.0-beta.0",
"v1.5.0",
"v1.4.1-beta.1",
"v1.4.1-beta.0",
"v1.4.1",
"v1.4.0-beta.2",
"v1.4.0",
"v1.3.1",
"v1.3.0",
"v1.3.0-beta.6",
"v1.3.0-beta.5",
"v1.3.0-beta.4",
"v1.3.0-beta.1",
"v1.3.0-beta.0",
"v1.3.0-beta.3",
"v1.3.0-beta.2",
"v1.2.2",
"v1.2.1",
"v1.2.0-beta.1",
"v1.2.0-beta.0",
"v1.2.0",
"v1.1.0",
"v1.0.2",
"v1.0.1",
"v1.0.0-beta.6",
"v1.0.0-beta.5",
"v1.0.0",
"v1.0.0-beta.4",
"v1.0.0-beta.3",
"v1.0.0-beta.2",
"v1.0.0-beta.1",
"v1.0.0-beta.0",
"v0.6.4-beta.1",
"v0.6.4",
"v0.6.4-beta.0",
"v0.6.3",
"v0.6.2",
"v0.6.1-beta.0",
"v0.6.1",
"v0.6.0",
"v0.6.0-alpha.1",
"v0.5.0",
"v0.5.0-beta.1",
"v0.4.0",
"v0.3.9",
"v0.3.8",
"v0.3.7",
"v0.3.6",
"v0.3.5",
"v0.3.4",
"v0.3.3",
"v0.3.2",
"v0.3.2-beta.3",
"v0.3.2-beta.1",
"v0.3.2-beta.0",
"v0.3.1",
"v0.3.0",
"v0.2.0",
"v0.1.1",
"v0.1.0",
"v0.0.1-beta.40",
"v0.0.1-beta.39",
"v0.0.1-beta.38",
"v0.0.1-beta.37",
"v0.0.1-beta.36",
"v0.0.1-beta.35",
"v0.0.1-beta.34",
"v0.0.1-beta.33",
"v0.0.1-beta.32",
"v0.0.1-beta.31",
"v0.0.1-beta.30",
"v0.0.1-beta.29",
"v0.0.1-beta.28",
"v0.0.1-beta.27",
"v0.0.1-beta.26",
"v0.0.1-beta.25",
"v0.0.1-beta.24",
"v0.0.1-beta.16",
"v0.0.1-beta.15",
"v0.0.1-beta.14",
"v0.0.1-beta.13",
"v0.0.1-beta.12",
"v0.0.1-beta.11",
"v0.0.1-beta.10",
"v0.0.1-beta.8",
"v0.0.1-beta.7",
"v0.0.1-beta.6",
"v0.0.1-beta.5",
"v0.0.1-beta.4",
"v0.0.1-beta.3",
"v0.0.1-beta.2",
"v0.0.1-beta.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-42457.json"
}
}
],
"modified": "2026-10-28T02:30:30.816951543Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42457.json",
"https://github.com/loft-sh/loft/security/advisories/GHSA-x7cq-v3h6-426c",
"https://nvd.nist.gov/vuln/detail/CVE-2026-42457"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "4.5.0-alpha.0"
},
{
"fixed": "4.5.5"
},
{
"introduced": "4.6.0-alpha.1"
},
{
"fixed": "4.6.2"
},
{
"introduced": "4.7.0-alpha.0"
},
{
"fixed": "4.7.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42457.json"
}
},
"related_cves": [
{
"value": "CVE-2026-42457",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 497625,
"published_at": "2026-05-14T14:48:05.096+00:00"
}