MediumFix available
kodi — security advisory
Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.
- Products
- kodi
- Affected versions
- Not specified
- Fixed versions
- 2:19.3+dfsg1-1
- CVEs
- CVE-2021-42917
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 01:08 UTC · Revision 1
Source evidence
Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.
osv:DEBIAN-CVE-2021-42917
kodi
Fixed versions: 2:19.3+dfsg1-1
kodi
Fixed versions: 2:19.3+dfsg1-1
kodi
Fixed versions: 2:19.3+dfsg1-1
Complete source record
{
"id": "2cb133f2cd48a97352d37b20821710883f5305e91eecaeeef562a3c9d10ba663",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-42917",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2021-42917",
"summary": "Buffer overflow vulnerability in Kodi xbmc up to 19.0, allows attackers to cause a denial of service due to improper length of values passed to istream.",
"evidence": "osv:DEBIAN-CVE-2021-42917",
"products": [
{
"name": {
"value": "kodi",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:19.3+dfsg1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "kodi",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:19.3+dfsg1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "kodi",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "2:19.3+dfsg1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2021-42917",
"aliases": [
"DEBIAN-CVE-2021-42917"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:19.3+dfsg1-1"
}
]
}
],
"package": {
"name": "kodi",
"purl": "pkg:deb/debian/kodi?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-42917.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:19.3+dfsg1-1"
}
]
}
],
"package": {
"name": "kodi",
"purl": "pkg:deb/debian/kodi?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-42917.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "2:19.3+dfsg1-1"
}
]
}
],
"package": {
"name": "kodi",
"purl": "pkg:deb/debian/kodi?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-42917.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-23T18:04:16.713405278Z",
"provider": "osv",
"upstream": [
"CVE-2021-42917"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2021-42917"
]
},
"related_cves": [
{
"value": "CVE-2021-42917",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 423120,
"published_at": "2021-11-01T19:15:07.91+00:00"
}