ZDI-CAN-24744: Mintty Path Conversion Improper Input Validation Information Disclosure Vulnerability
Mintty is a terminal emulator for Cygwin, MSYS, and WSL. In versions 2.3.6 through 3.7.4, several escape sequences can cause the mintty process to access a file in a specific path. It is triggered by simply printing them out on bash. An attacker can specify an arbitrary network path, negotiate an ntlm hash out of the victim's machine to an attacker controlled remote host. An attacker can use password cracking tools or NetNTLMv2 hashes to Pass the Hash. Version 3.7.5 fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-45301
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 04:52 UTC · Revision 1
Source evidence
ZDI-CAN-24744: Mintty Path Conversion Improper Input Validation Information Disclosure Vulnerability
core-osv · Original sourcePublished 12 Nov 2025, 18:26 UTC
Mintty is a terminal emulator for Cygwin, MSYS, and WSL. In versions 2.3.6 through 3.7.4, several escape sequences can cause the mintty process to access a file in a specific path. It is triggered by simply printing them out on bash. An attacker can specify an arbitrary network path, negotiate an ntlm hash out of the victim's machine to an attacker controlled remote host. An attacker can use password cracking tools or NetNTLMv2 hashes to Pass the Hash. Version 3.7.5 fixes the issue.
osv:CVE-2024-45301
Complete source record
{
"id": "97a8b4aaa9c7410c18fd0a16ada47b6a7458aabfe8db40ca8c788df610f69d43",
"url": "https://osv.dev/vulnerability/CVE-2024-45301",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ZDI-CAN-24744: Mintty Path Conversion Improper Input Validation Information Disclosure Vulnerability",
"summary": "Mintty is a terminal emulator for Cygwin, MSYS, and WSL. In versions 2.3.6 through 3.7.4, several escape sequences can cause the mintty process to access a file in a specific path. It is triggered by simply printing them out on bash. An attacker can specify an arbitrary network path, negotiate an ntlm hash out of the victim's machine to an attacker controlled remote host. An attacker can use password cracking tools or NetNTLMv2 hashes to Pass the Hash. Version 3.7.5 fixes the issue.",
"evidence": "osv:CVE-2024-45301",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-45301",
"aliases": [
"CVE-2024-45301",
"GHSA-jf4m-m6rv-p6c5"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/mintty/mintty",
"type": "GIT",
"events": [
{
"introduced": "698b7259f633eed5412148062af20cf7a1bd0c76"
},
{
"fixed": "2b585cc77fbf671300395c56a8cc1da5e71992fa"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2.3.6"
},
{
"fixed": "3.7.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"introduced": "2.3.6"
},
{
"last_affected": "3.7.4"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"3.7.4",
"3.7.3",
"3.7.2",
"3.7.1",
"3.7.0",
"3.6.5",
"3.6.4",
"3.6.3",
"3.6.2",
"3.6.1",
"3.6.0",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.0",
"3.4.7",
"3.4.6",
"3.4.5",
"3.4.4",
"3.4.3",
"3.4.2",
"3.4.1",
"3.4.0",
"3.3.0",
"3.2.0",
"3.1.8",
"3.1.7",
"3.1.6",
"3.1.5",
"3.1.4",
"3.1.0",
"3.0.6",
"3.0.5",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"3.0.0",
"2.9.9",
"2.9.8",
"2.9.7",
"2.9.6",
"2.9.5",
"2.9.4",
"2.9.3",
"2.9.2",
"2.9.1",
"2.9.0",
"2.8.5",
"2.8.4",
"2.8.3",
"2.8.2",
"2.8.1",
"2.8.0",
"2.7.9",
"2.7.8",
"2.7.7",
"2.7.6",
"2.7.5",
"2.7.4",
"2.7.3",
"2.7.2",
"2.7.1",
"2.7.0",
"2.6.2",
"2.6.1",
"2.6.0",
"2.5.1",
"2.5.0",
"2.4.3",
"2.4.2",
"2.4.1",
"2.4.0",
"2.3.7release",
"2.3.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-45301.json"
}
}
],
"modified": "2026-10-28T02:30:33.499702190Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45301.json",
"https://github.com/mintty/mintty/security/advisories/GHSA-jf4m-m6rv-p6c5",
"https://nvd.nist.gov/vuln/detail/CVE-2024-45301"
],
"provider_metadata": {
"cwe_ids": [
"CWE-20"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/45xxx/CVE-2024-45301.json"
}
},
"related_cves": [
{
"value": "CVE-2024-45301",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 500406,
"published_at": "2025-11-12T18:26:34.904+00:00"
}