Improper Neutralization of Alternate XSS Syntax in Knowage-Server
Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39295
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 08:21 UTC · Revision 1
Source evidence
Improper Neutralization of Alternate XSS Syntax in Knowage-Server
core-osv · Original sourcePublished 13 Oct 2022, 00:00 UTC
Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.
osv:CVE-2022-39295
Complete source record
{
"id": "d8d5f8023d57ccb9ca4e566f491f9031be9ae5c33cf54c02183083fad51f5a4c",
"url": "https://osv.dev/vulnerability/CVE-2022-39295",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Improper Neutralization of Alternate XSS Syntax in Knowage-Server",
"summary": "Knowage is an open source suite for modern business analytics alternative over big data systems. KnowageLabs / Knowage-Server starting with the 6.x branch and prior to versions 7.4.22, 8.0.9, and 8.1.0 is vulnerable to cross-site scripting because the `XSSRequestWrapper::stripXSS` method can be bypassed. Versions 7.4.22, 8.0.9, and 8.1.0 contain patches for this issue. There are no known workarounds.",
"evidence": "osv:CVE-2022-39295",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-39295",
"aliases": [
"CVE-2022-39295",
"GHSA-f2gr-6h9j-rwcw"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/knowagelabs/knowage-server",
"type": "GIT",
"events": [
{
"introduced": "eb0a58ddc4badcbf4502ca523cf415743c023aa0"
},
{
"fixed": "78dfd58032699b2f11264654d5f9ce8f9701ed66"
},
{
"introduced": "96bdab85f1d4b32ecbac0d277f494d5e3c16b907"
},
{
"fixed": "9ef26550ac874f26cf19ea35e3c373742e7de38f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "6.1.0"
},
{
"fixed": "7.4.22"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:eng:knowage:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.0.9"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v8.0.8",
"v8.0.7",
"v8.0.6",
"v8.0.5",
"v8.0.4",
"v8.0.3",
"v8.0.2",
"v8.0.1",
"v8.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39295.json"
}
}
],
"modified": "2026-10-28T02:30:27.269881534Z",
"provider": "osv",
"references": [
"https://github.com/KnowageLabs/Knowage-Server/blob/b079a654c1708f82f6914c55be6715ad621d9edd/knowageutils/src/main/java/it/eng/spagobi/utilities/filters/XSSRequestWrapper.java#L82-L206",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39295.json",
"https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-f2gr-6h9j-rwcw",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39295"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79",
"CWE-87"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39295.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39295",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493751,
"published_at": "2022-10-13T00:00:00+00:00"
}