High
Auth0 PHP SDK Insufficient Entropy in Cookie Encryption
Type: advisorySources: OSV
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-34236
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 03:59 UTC · Revision 1
Source evidence
Auth0 PHP SDK Insufficient Entropy in Cookie Encryption
core-osv · Original sourcePublished 1 Apr 2026, 17:04 UTC
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
osv:CVE-2026-34236
Complete source record
{
"id": "9f370024bd5ec9a597c8bbcdd8517e61cee271ad774c8a099509b3bf7b41e9b1",
"url": "https://osv.dev/vulnerability/CVE-2026-34236",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Auth0 PHP SDK Insufficient Entropy in Cookie Encryption",
"summary": "Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.",
"evidence": "osv:CVE-2026-34236",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-34236",
"aliases": [
"CVE-2026-34236",
"GHSA-w3wc-44p4-m4j7"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/auth0/auth0-php",
"type": "GIT",
"events": [
{
"introduced": "57caf1cc0ab3b6f5ef6615db364fdc3261749fc0"
},
{
"fixed": "043ddd31e75ce383c6060c30c683cfa3b5dd8c3b"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.19.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"range": [
{
"fixed": "043ddd31e75ce383c6060c30c683cfa3b5dd8c3b"
}
],
"source": "REFERENCES_TAG",
"original_tag": "8.19.0"
},
{
"cpe": "cpe:2.3:a:auth0:auth0-php:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "8.0.0"
},
{
"fixed": "8.19.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"8.18.0",
"8.17.0",
"8.16.0",
"8.15.0",
"8.14.0",
"8.13.0",
"8.12.0",
"8.11.1",
"8.11.0",
"8.10.0",
"8.9.3",
"8.9.1",
"8.9.0",
"8.8.0",
"8.7.1",
"8.7.0",
"8.6.0",
"8.5.0",
"8.4.0",
"8.3.7",
"8.3.6",
"8.3.5",
"8.3.4",
"8.3.3",
"8.3.2",
"8.3.1",
"8.3.0",
"8.2.1",
"8.2.0",
"8.1.0",
"8.0.6",
"8.0.5",
"8.0.4",
"8.0.3",
"8.0.2",
"8.0.1",
"8.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-34236.json"
}
}
],
"modified": "2026-10-28T02:30:49.533671788Z",
"provider": "osv",
"references": [
"https://github.com/auth0/auth0-PHP/releases/tag/8.19.0",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34236.json",
"https://github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7",
"https://nvd.nist.gov/vuln/detail/CVE-2026-34236"
],
"provider_metadata": {
"cwe_ids": [
"CWE-331"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34236.json"
}
},
"related_cves": [
{
"value": "CVE-2026-34236",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 517948,
"published_at": "2026-04-01T17:04:53.378+00:00"
}