OpenSIPS has vulnerability in the ds_is_in_list() function
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, if `ds_is_in_list()` is used with an invalid IP address string (`NULL` is illegal input), OpenSIPS will attempt to print a string from a random address (stack garbage), which could lead to a crash. All users of `ds_is_in_list()` without the `$si` variable as 1st parameter could be affected by this vulnerability to a larger, lesser or no extent at all, depending if the data passed to the function is a valid IPv4 or IPv6 address string or not. Fixes will are available starting with the 3.1.9 and 3.2.6 minor releases. There are no known workarounds.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-28099
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 03:49 UTC · Revision 1
Source evidence
OpenSIPS has vulnerability in the ds_is_in_list() function
core-osv · Original sourcePublished 15 Mar 2023, 22:16 UTC
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, if `ds_is_in_list()` is used with an invalid IP address string (`NULL` is illegal input), OpenSIPS will attempt to print a string from a random address (stack garbage), which could lead to a crash. All users of `ds_is_in_list()` without the `$si` variable as 1st parameter could be affected by this vulnerability to a larger, lesser or no extent at all, depending if the data passed to the function is a valid IPv4 or IPv6 address string or not. Fixes will are available starting with the 3.1.9 and 3.2.6 minor releases. There are no known workarounds.
osv:CVE-2023-28099
Complete source record
{
"id": "40b9f198d241acb01f5bc8f19f919524b9d111cce0b330cbf59e1cdc99a134ec",
"url": "https://osv.dev/vulnerability/CVE-2023-28099",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "OpenSIPS has vulnerability in the ds_is_in_list() function",
"summary": "OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.9 and 3.2.6, if `ds_is_in_list()` is used with an invalid IP address string (`NULL` is illegal input), OpenSIPS will attempt to print a string from a random address (stack garbage), which could lead to a crash. All users of `ds_is_in_list()` without the `$si` variable as 1st parameter could be affected by this vulnerability to a larger, lesser or no extent at all, depending if the data passed to the function is a valid IPv4 or IPv6 address string or not. Fixes will are available starting with the 3.1.9 and 3.2.6 minor releases. There are no known workarounds.",
"evidence": "osv:CVE-2023-28099",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-28099",
"aliases": [
"CVE-2023-28099",
"GHSA-pfm5-6vhv-3ff3"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/opensips/opensips",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "949719bf4baeb5da9787b9c4191e061fe800d9eb"
},
{
"introduced": "1e94abe8837fe3511fada132d67a6385d8d099a2"
},
{
"fixed": "ce8cda891ce6cc48ff7dc2e75f683e4e45798c6c"
},
{
"fixed": "e2f13d374"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.9"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:opensips:opensips:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.2.0"
},
{
"fixed": "3.2.6"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "e2f13d374"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"3.1.8",
"3.2.5",
"3.2.4",
"3.1.7",
"3.2.3",
"3.1.6",
"3.2.2",
"3.1.5",
"3.1.4",
"3.2.1",
"3.2.0",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.1.0-beta",
"2.1-rc1",
"2.1-alpha3",
"2.1-alpha2",
"2.1-alpha1",
"1.11.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-28099.json"
}
}
],
"modified": "2026-10-28T02:30:46.406062727Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28099.json",
"https://github.com/OpenSIPS/opensips/security/advisories/GHSA-pfm5-6vhv-3ff3",
"https://nvd.nist.gov/vuln/detail/CVE-2023-28099",
"https://github.com/OpenSIPS/opensips/issues/2780",
"https://github.com/OpenSIPS/opensips/commit/e2f13d374"
],
"provider_metadata": {
"cwe_ids": [
"CWE-20"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/28xxx/CVE-2023-28099.json"
}
},
"related_cves": [
{
"value": "CVE-2023-28099",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514531,
"published_at": "2023-03-15T22:16:57.958+00:00"
}